Bug 177302 - German umlaute (like äüö) doesn't work with aterm
German umlaute (like äüö) doesn't work with aterm
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: aterm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-09 06:59 EST by JM
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 17:47:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JM 2006-01-09 06:59:09 EST
It's not possible to use german umlaute (like äüö) with aterm and for example
the "Home" and "End" key doesn't work.
Comment 1 Andreas Bierfert 2006-01-09 15:38:46 EST
Aterm not being able to view these special german characters is not part of a
bug in FE. You probably use a utf8 locale whereas aterm does not support utf8.
Either switch to a non utf8 german locale (with all implications) or switch to a
terminal which supports utf8 (rxvt-unicode would be my choice).

Home and End key not working might be a termcap issue? Since when is this not
working for you? Maybe since the latest termcap upgrade a couple of days ago?
Comment 2 JM 2006-01-10 06:57:50 EST
Then the German Umlaute problem is not a bug, it's a feature of aterm :-) but
for the Home and End key I still have the problem that it doesn't work right out
of the box.

I use now the aterm from the Dries-RPM
(http://dries.ulyssis.org/rpm/packages/aterm/info.html) and there the Home and
End key works without any modifications on my side.

I can't tell you if the FE-RPM has problems since the latest termcap upgrade
because I installed it the first time (on FC4) yesterday :-).

Comment 3 Andreas Bierfert 2006-01-14 03:36:14 EST
Ok, could you test if the end key works? I can only reproduce the home key not
working and this could be due to a false default setting. I suspect that
building with aterm settings set to xterm would solve the problem.
Comment 4 JM 2006-01-19 10:10:16 EST
You are right, the End key works. 

Only the Home key creates the character '~' instead going to the first position. 

I thought that the End key doesn't work because of the german characters, these
characters mess up everything so that it looked like the End key has problems too.
Comment 5 Andreas Bierfert 2006-02-28 17:47:47 EST
Fixed.

Note You need to log in before you can comment on or make changes to this bug.