Bug 177307 - No search/domain line in /etc/resolv.conf
No search/domain line in /etc/resolv.conf
Status: CLOSED DUPLICATE of bug 182011
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-09 09:23 EST by Daniel Walsh
Modified: 2007-12-18 10:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 10:21:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2006-01-09 09:23:53 EST
Description of problem:

resolv.conf does not pick up my search line from /etc/dhclient.conf.  I end up
with no search or domain line.   So I end up manually editing it.

Not good for usability
Comment 1 David Zeuthen 2006-01-09 10:13:14 EST
Reassigning to NetworkManager maintainer
Comment 2 Jeff Gustafson 2006-03-22 15:19:58 EST
I know at one time NetworkManager was supposed to notify a running bind process
what the new DNS servers were.  In that case, the DNS server was supposed to be
localhost.  If that's what you're seeing, then it's working.

Right now I'm seeing that /etc/resolv.conf has the normal entries even though
I'm running bind.  I wish I could get it to work the other way (with bind on
localhost).
Comment 3 Denis Leroy 2006-09-28 19:36:49 EDT
Taking ownership.
Comment 4 Denis Leroy 2006-10-19 16:58:34 EDT
Is this bug still occuring ? Is it NetworkManager-vpnc specific or is it a
general NM issue ? Can you attach your dhclient.conf file, and also verify that
it is syntactially correct ? (see /var/log/messages). I'm not even sure you can
supersede the search entries...

If I don't hear from submitter, will close in a week as WORKSFORME.
Comment 5 Daniel Walsh 2006-10-20 09:43:36 EDT
Seems to work with Standard Network Manager plugged into wire and on the rh-wireless

Definitly broken on NetworkManager-vpnc

rpm -q NetworkManager-vpnc
NetworkManager-vpnc-0.7.0-0.cvs20060929.2.fc6

With vpnc
cat /etc/resolv.conf
# generated by NetworkManager, do not edit!



nameserver 172.16.52.28
nameserver 10.11.255.27

With just Wireless
cat /etc/resolv.conf
# generated by NetworkManager, do not edit!

search redhat.com redhat.com lab.boston.redhat.com


nameserver 66.187.224.210
nameserver 66.187.233.210

Comment 6 Denis Leroy 2006-11-08 09:43:03 EST
Reassigning to vpnc, I don't see how this issue could be caused by n-m-vpnc
unfortunately... 
Comment 7 Tomas Mraz 2006-12-11 14:31:52 EST
The vpnc doesn't pick the search lines from dhclient.conf because it doesn't use
dhcp at all.

The vpnc's own interface init script (which is probably not in use when vpnc is
called from NetworkManager-vpnc) preserves search lines from the original
/etc/resolv.conf.

So either WONTFIX or back to NetworkManager-vpnc.
Comment 8 Denis Leroy 2007-12-18 10:21:39 EST

*** This bug has been marked as a duplicate of 182011 ***

Note You need to log in before you can comment on or make changes to this bug.