Bug 1773148 - sudo: setrlimit(RLIMIT_CORE): Operation not permitted
Summary: sudo: setrlimit(RLIMIT_CORE): Operation not permitted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sudo
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Attila Lakatos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-11-16 01:53 UTC by Jason Montleon
Modified: 2020-08-28 15:58 UTC (History)
13 users (show)

Fixed In Version: sudo-1.9.0-0.1.b1.fc31 sudo-1.9.0-0.1.b1.fc32 sudo-1.9.0-0.1.b4.fc32 sudo-1.9.0-0.1.b4.fc31 sudo-1.8.31p1-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-30 00:17:10 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github sudo-project sudo issues 42 None closed in container: sudo: setrlimit(RLIMIT_CORE): Operation not permitted 2020-08-28 15:58:26 UTC

Description Jason Montleon 2019-11-16 01:53:32 UTC
Description of problem:

Version-Release number of selected component (if applicable):
sudo-1.8.29-1.fc31.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run Fedora in an lxc container
2. Update sudo to sudo-1.8.29-1.fc31.x86_64
3. Run sudo

Actual results:
sudo works, but emits an error

Expected results:
no errors are produced.

Additional info:
This did not happen with sudo-1.8.28-1.fc31.x86_64

[jason@penguin ~]$ rpm -q sudo
sudo-1.8.28-1.fc31.x86_64
[jason@penguin ~]$ sudo su -
Last login: Fri Nov 15 20:47:32 EST 2019 on pts/0
[root@penguin ~]# dnf update -y
Last metadata expiration check: 0:07:40 ago on Fri 15 Nov 2019 08:40:07 PM EST.
Dependencies resolved.
====================================================================================================================================================
 Package                        Architecture                     Version                                    Repository                         Size
====================================================================================================================================================
Upgrading:
 sudo                           x86_64                           1.8.29-1.fc31                              updates                           908 k

Transaction Summary
====================================================================================================================================================
Upgrade  1 Package

Total download size: 908 k
Downloading Packages:
sudo-1.8.29-1.fc31.x86_64.rpm                                                                                       1.0 MB/s | 908 kB     00:00    
----------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                               830 kB/s | 908 kB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                            1/1 
  Upgrading        : sudo-1.8.29-1.fc31.x86_64                                                                                                  1/2 
  Running scriptlet: sudo-1.8.29-1.fc31.x86_64                                                                                                  1/2 
  Cleanup          : sudo-1.8.28-1.fc31.x86_64                                                                                                  2/2 
  Running scriptlet: sudo-1.8.28-1.fc31.x86_64                                                                                                  2/2 
  Verifying        : sudo-1.8.29-1.fc31.x86_64                                                                                                  1/2 
  Verifying        : sudo-1.8.28-1.fc31.x86_64                                                                                                  2/2 

Upgraded:
  sudo-1.8.29-1.fc31.x86_64                                                                                                                         

Complete!
[root@penguin ~]# logout
[jason@penguin ~]$ sudo su -
sudo: setrlimit(RLIMIT_CORE): Operation not permitted
Last login: Fri Nov 15 20:47:41 EST 2019 on pts/0
[root@penguin ~]#

Comment 1 Jason Montleon 2019-11-16 14:01:37 UTC
As a workaround to get rid of the error I can do the following:

$ cat /etc/sudo.conf 
Set disable_coredump false

Comment 2 Fedora Update System 2020-03-04 09:58:22 UTC
FEDORA-2020-7c1b270959 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7c1b270959

Comment 3 Fedora Update System 2020-03-04 20:15:00 UTC
sudo-1.9.0-0.1.b1.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7c1b270959

Comment 4 Fedora Update System 2020-03-04 21:49:16 UTC
sudo-1.9.0-0.1.b1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-8b563bc5f4

Comment 5 Jens Petersen 2020-03-06 02:15:51 UTC
sudo-1.9.0-0.1.b1 does not seem to fix the problem for me inside my toolboxes.

Comment 6 Fedora Update System 2020-03-06 02:23:32 UTC
sudo-1.9.0-0.1.b1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Jason Montleon 2020-03-06 13:18:36 UTC
This new package does not fix the problem:

$ sudo rpm -q sudo
sudo: setrlimit(RLIMIT_CORE): Operation not permitted
sudo-1.9.0-0.1.b1.fc31.x86_64

Comment 8 Jens Petersen 2020-03-14 04:36:28 UTC
I am wondering should the fedora container be allowed to set RLIMIT_CORE?
I don't really see why not: maybe this CAP is determined by podman/buildah?

At least this didn't happen earlier...

Comment 9 Jens Petersen 2020-03-14 05:02:25 UTC
But I guess it is something new that sudo is doing since 1.8.29.

I opened a ticket in github: https://github.com/sudo-project/sudo/issues/42

Comment 10 Jens Petersen 2020-03-16 04:48:13 UTC
Upstream released a fix in 1.8.31p1.

Comment 11 Fedora Update System 2020-03-16 20:21:49 UTC
sudo-1.9.0-0.1.b1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2020-03-16 20:33:02 UTC
sudo-1.9.0-0.1.b1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Jens Petersen 2020-03-17 01:54:25 UTC
Please remove the bug from Bodhi next time :)

Comment 14 Jens Petersen 2020-03-24 08:44:23 UTC
I think this will get fixed in sudo 1.9.0b5.

Also dunno why we are shipping a beta release of sudo in F31?

Comment 15 Jens Petersen 2020-03-24 08:45:48 UTC
(It is already fixed in the sudo 1.8.31p1 release.)

Comment 16 Jens Petersen 2020-03-24 08:56:14 UTC
But can we update to 1.9.0b4 first in F32+?
To test it more before 1.9.0b5 is released.

Comment 17 Radovan Sroka 2020-03-24 10:28:45 UTC
(In reply to Jens Petersen from comment #14)
> I think this will get fixed in sudo 1.9.0b5.
> 
> Also dunno why we are shipping a beta release of sudo in F31?

Sudo beta releases are stable enough and we need proper testing before 1.9.0 stable.

Also me and @alakatos were wondering about waiting for 1.9.0 stable now, cause we don't have
much time for rebases.

Comment 18 Jens Petersen 2020-03-24 11:14:11 UTC
https://src.fedoraproject.org/rpms/sudo/pull-request/13 (see also bug 1816593).

Comment 19 Jens Petersen 2020-03-24 11:16:51 UTC
(In reply to Radovan Sroka from comment #17)
> Sudo beta releases are stable enough and we need proper testing before 1.9.0
> stable.

Sure it is your call - I am not very familiar with sudo releases etc.

> Also me and @alakatos were wondering about waiting for 1.9.0 stable now,
> cause we don't have much time for rebases.

Anyway bug is already fixed in the 1.8.31p1 release...
https://www.sudo.ws/pipermail/sudo-announce/2020-March/000172.html

Comment 20 Jens Petersen 2020-03-26 05:23:01 UTC
(In reply to Jens Petersen from comment #18)
> https://src.fedoraproject.org/rpms/sudo/pull-request/13 (see also bug
> 1816593).

Working fine for me here.

Comment 21 Attila Lakatos 2020-03-26 08:21:15 UTC
(In reply to Jens Petersen from comment #18)
> https://src.fedoraproject.org/rpms/sudo/pull-request/13 (see also bug
> 1816593).

Can you update the PR, so we can merge it? There have been some changes in master since you opened the PR.

Comment 22 Jens Petersen 2020-03-26 10:57:37 UTC
Done, thanks

Comment 23 Fedora Update System 2020-03-27 09:24:54 UTC
FEDORA-2020-034d5a4cae has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-034d5a4cae

Comment 24 Fedora Update System 2020-03-27 09:50:41 UTC
FEDORA-2020-242921ccb4 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-242921ccb4

Comment 25 Jens Petersen 2020-03-27 11:18:59 UTC
Thanks for the updates

Just noting that this also affects f30 - if f30 was updated to 1.8.31p1
that would make the warning go away, I think.

Comment 26 Attila Lakatos 2020-03-27 13:29:40 UTC
(In reply to Jens Petersen from comment #25)
> Thanks for the updates
> 
> Just noting that this also affects f30 - if f30 was updated to 1.8.31p1
> that would make the warning go away, I think.

That makes sense to me and I agree with you. Thank you.

Comment 27 Fedora Update System 2020-03-27 14:59:23 UTC
FEDORA-2020-b3edb41afd has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b3edb41afd

Comment 28 Fedora Update System 2020-03-28 02:42:54 UTC
FEDORA-2020-242921ccb4 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-242921ccb4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-242921ccb4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 29 Fedora Update System 2020-03-28 03:36:37 UTC
FEDORA-2020-b3edb41afd has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b3edb41afd`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b3edb41afd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 30 Fedora Update System 2020-03-28 14:59:07 UTC
FEDORA-2020-034d5a4cae has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-034d5a4cae`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-034d5a4cae

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 31 Fedora Update System 2020-03-30 00:17:10 UTC
FEDORA-2020-034d5a4cae has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 32 Fedora Update System 2020-04-10 16:15:44 UTC
FEDORA-2020-242921ccb4 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 33 Fedora Update System 2020-04-11 21:51:02 UTC
FEDORA-2020-b3edb41afd has been pushed to the Fedora 30 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.