Bug 1773172 - Update biber to work with the latest texlive update
Summary: Update biber to work with the latest texlive update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: biber
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Macdonald
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-16 07:53 UTC by hannes
Modified: 2019-11-19 01:36 UTC (History)
6 users (show)

Fixed In Version: biber-2.12-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-19 01:36:02 UTC
Type: Bug


Attachments (Terms of Use)

Description hannes 2019-11-16 07:53:29 UTC
Description of problem:
Currently, when using biber in conjunction with texlive. There is an error that the versions don't match:
Process started: biber "201908_LoansOilIndustry_Article"

INFO - This is Biber 2.11
INFO - Logfile is '201908_LoansOilIndustry_Article.blg'
INFO - Reading '201908_LoansOilIndustry_Article.bcf'
ERROR - Error: Found biblatex control file version 3.5, expected version 3.4.
This means that your biber (2.11) and biblatex (3.12) versions are incompatible.
See compat matrix in biblatex or biber PDF documentation.
INFO - ERRORS: 1

Process exited with error(s)

Version-Release number of selected component (if applicable):
biber - 2.11-6

How reproducible:
Compile tex file with biblatex and execute biber afterwards.


Actual results:
Citations are not displayed.

Expected results:
Citations are properly displayed in the document.

Comment 1 hannes 2019-11-16 08:17:50 UTC
It should be updated to 2.12, not to the latest version 2.13, because this would then again be incompatible.

Comment 2 Fedora Update System 2019-11-17 23:26:12 UTC
FEDORA-2019-4f075bc426 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4f075bc426

Comment 3 Fedora Update System 2019-11-18 02:15:12 UTC
biber-2.12-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4f075bc426

Comment 4 hannes 2019-11-18 13:40:15 UTC
On a related note, would it be somehow possible to check the compatibility of the versions on the rpm level? I mean could texlive require the necessary version of the biber package?
This would prevent this from happening again.

Comment 5 Colin Macdonald 2019-11-18 20:23:41 UTC
Yeah it should definitely be improved.  See #1561929.  Would be happy for your help/input/debugging over there: I don't really know enough about texlive packaging to accomplish what I want to happen (see TODOs at top of spec file and comments by @spot).

Comment 6 Fedora Update System 2019-11-19 01:36:02 UTC
biber-2.12-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.