Bug 177334 - LDBM Plug-in Settings console UI value checking issues
LDBM Plug-in Settings console UI value checking issues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Directory Server
Classification: Red Hat
Component: UI - Configuration (Show other bugs)
7.1
All Linux
low Severity medium
: DS8.1
: ---
Assigned To: Noriko Hosoi
Chandrasekar Kannan
:
: 306201 (view as bug list)
Depends On:
Blocks: 152373 249650 FDS1.2.0
  Show dependency treegraph
 
Reported: 2006-01-09 14:47 EST by To Ngan
Modified: 2015-01-04 18:19 EST (History)
5 users (show)

See Also:
Fixed In Version: 8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 18:58:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs (3.17 KB, patch)
2008-12-11 12:24 EST, Rich Megginson
no flags Details | Diff
cvs commit log (236 bytes, text/plain)
2008-12-11 15:46 EST, Rich Megginson
no flags Details

  None (edit)
Description To Ngan 2006-01-09 14:47:43 EST
Description of problem:
Issue regarding the value fields on DS console LDBM Plug-in Settings pane.

Version-Release number of selected component (if applicable):
DS 7.1 SP1

How reproducible:
Consistently.

Steps to Reproduce:
1. Open DS console - Configuration -> Database Settings -> LDBM Plug-in Settings
2. Input fields# 1, 2 and 4 ... the max allowed input value by the UI is
9223372036854775807
3. Type that in and press Save
  
Actual results:
An error dialog pops up saying "LDAP server is unwilling to perform..."
However, if press OK and attempt to Save again, DS will save the bad value this
time without error.

Expected results:
The UI check should disable the Save button if input is out of bound.  The
look-through limit (field #2) is supposed to be 2147483647.  Not 100% sure about
field #1 and #4.
Comment 3 Rich Megginson 2008-12-11 12:24:35 EST
Created attachment 326639 [details]
diffs
Comment 4 Rich Megginson 2008-12-11 15:46:54 EST
Created attachment 326670 [details]
cvs commit log

Reviewed by: nkinder (Thanks!)
Fix Description: The code was unconditionally resetting the field before checking the result of the modify operation.  The correct way to do it is to reset the field only after the modify operation succeeded.   I create a Vector of fields that are being modified, and only reset them if the modify succeeded.
Platforms tested: RHEL5
Flag Day: no
Doc impact: no
Comment 5 Rich Megginson 2008-12-11 16:03:06 EST
*** Bug 306201 has been marked as a duplicate of this bug. ***
Comment 6 Jenny Galipeau 2009-03-11 11:09:28 EDT
Fix verified: DS 8.1 RHEL 5

UI continues to error if you try to save the bad value for fields 1,2 and 4 and the value is not changed in the directory server's configuration.
Comment 7 Chandrasekar Kannan 2009-04-29 18:58:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0455.html

Note You need to log in before you can comment on or make changes to this bug.