Bug 1773345 - Problems with HP M281fdw LaserJet (HP-ColorLaserJet-MFP-M278-M281)
Summary: Problems with HP M281fdw LaserJet (HP-ColorLaserJet-MFP-M278-M281)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 31
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-17 19:18 UTC by Jan Vlug
Modified: 2019-11-27 00:23 UTC (History)
4 users (show)

Fixed In Version: hplip-3.19.10-2.fc30 hplip-3.19.10-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-26 23:51:46 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1851013 0 None None None 2019-11-17 19:52:26 UTC

Description Jan Vlug 2019-11-17 19:18:45 UTC
I have problems again with accessing my HP M281fdw LaserJet printer. It started with the fact that scanning did not work any more.

See bug 1694663 for details on problems that I had before.

In an attempt to get my LaserJet scanning again, I installed hp-plugin. The scanner did still not work. Next, I removed
/usr/share/hplip/data/models/models.dat
because I did this in the past once as well, and reinstalled hplip:
# dnf reinstall hplip*

Next I removed the two entries of the LaserJet in Gnome-Settings|Printers (the avahi discovered one and the previously manually added one).

Then I tried to reinstall the LaserJet from Gnome-Settings|Printers. But this results now in a Failed to add new printer popup window.

Here is an excerpt from my journal:

Nov 17 20:01:52 nyx gnome-shell[2579]: invalid (NULL) pointer instance
Nov 17 20:01:52 nyx gnome-shell[2579]: g_signal_handler_disconnect: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
Nov 17 20:01:54 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:01:54 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:01:58 nyx systemd[1]: Started dbus-:1.5-org.opensuse.CupsPkHelper.Mechanism.
Nov 17 20:01:58 nyx audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dbus-:1.5-org.opensuse.CupsPkHelper.Mechanism@2 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 17 20:01:58 nyx cupsd[1713]: REQUEST localhost - - "POST / HTTP/1.1" 401 98 CUPS-Get-Devices successful-ok
Nov 17 20:01:58 nyx cupsd[1713]: REQUEST localhost - root "POST / HTTP/1.1" 200 173 CUPS-Get-Devices -
Nov 17 20:01:58 nyx cupsd[1713]: REQUEST localhost - root "POST / HTTP/1.1" 200 327 CUPS-Get-Devices -
Nov 17 20:01:58 nyx cupsd[1713]: REQUEST localhost - root "POST / HTTP/1.1" 200 341 CUPS-Get-Devices -
Nov 17 20:01:58 nyx cupsd[1713]: REQUEST localhost - root "POST / HTTP/1.1" 200 323 CUPS-Get-Devices -
Nov 17 20:01:58 nyx cupsd[1713]: REQUEST localhost - root "POST / HTTP/1.1" 200 322 CUPS-Get-Devices -
Nov 17 20:01:58 nyx cupsd[1713]: REQUEST localhost - root "POST / HTTP/1.1" 200 331 CUPS-Get-Devices -
Nov 17 20:01:58 nyx hp[14620]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Nov 17 20:01:58 nyx cupsd[1713]: REQUEST localhost - root "POST / HTTP/1.1" 200 314 CUPS-Get-Devices -
Nov 17 20:01:59 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:01:59 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:02:00 nyx cupsd[1713]: REQUEST localhost - root "POST / HTTP/1.1" 200 859 CUPS-Get-Devices -
Nov 17 20:02:00 nyx systemd[2478]: Started dbus-:1.2-org.fedoraproject.Config.Printing.
Nov 17 20:02:03 nyx gnome-control-c[7233]: gdkwindow-x11.c:5633 drawable is not a native X11 window
Nov 17 20:02:04 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:02:04 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:02:04 nyx cupsd[1713]: REQUEST localhost - root "POST / HTTP/1.1" 200 1184 CUPS-Get-Devices -
Nov 17 20:02:08 nyx cupsd[1713]: REQUEST localhost - - "POST / HTTP/1.1" 200 6597237 CUPS-Get-PPDs -
Nov 17 20:02:09 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:02:09 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:02:09 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:02:09 nyx cupsd[1713]: [CGI] Cannot connect to remote printer ipp://NPIA997CD.local:631/ipp/print (NPIA997CD.local:631)
Nov 17 20:02:09 nyx cupsd[1713]: copy_model: empty PPD file
Nov 17 20:02:09 nyx cupsd[1713]: [Client 183] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/HP-ColorLaserJet-MFP-M278-M281) from localhost.
Nov 17 20:02:09 nyx cupsd[1713]: REQUEST localhost - root "POST /admin/ HTTP/1.1" 200 447 CUPS-Add-Modify-Printer server-error-internal-error
Nov 17 20:02:09 nyx gnome-control-c[7233]: cups-pk-helper: addition of printer HP-ColorLaserJet-MFP-M278-M281 failed: server-error-internal-error
Nov 17 20:02:10 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:02:11 nyx gnome-control-c[7233]: Installation of the new printer failed.
Nov 17 20:02:11 nyx gnome-control-c[7233]: gtk_widget_get_allocation: assertion 'GTK_IS_WIDGET (widget)' failed
Nov 17 20:02:11 nyx gnome-control-c[7233]: gtk_widget_get_margin_top: assertion 'GTK_IS_WIDGET (widget)' failed
Nov 17 20:02:11 nyx gnome-control-c[7233]: gtk_widget_draw: assertion '!widget->priv->alloc_needed' failed
Nov 17 20:02:14 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:02:14 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:02:19 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:02:19 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:02:20 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:02:24 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:02:24 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:02:29 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:02:29 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:02:34 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:02:34 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:02:39 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/53, but it's already registered
Nov 17 20:02:39 nyx gnome-keyring-daemon[2497]: asked to register item /org/freedesktop/secrets/collection/login/52, but it's already registered
Nov 17 20:02:40 nyx scp-dbus-service[14629]: /usr/share/system-config-printer/scp-dbus-service.py:602: DeprecationWarning: Gdk.threads_enter is deprecated
Nov 17 20:02:40 nyx scp-dbus-service[14629]:   Gdk.threads_enter ()
Nov 17 20:02:40 nyx systemd[1]: dbus-:1.5-org.opensuse.CupsPkHelper.Mechanism: Succeeded.
Nov 17 20:02:40 nyx audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dbus-:1.5-org.opensuse.CupsPkHelper.Mechanism@2 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 17 20:02:40 nyx systemd[2478]: dbus-:1.2-org.fedoraproject.Config.Printing: Succeeded.
Nov 17 20:02:40 nyx systemd[2478]: dbus-:1.2-org.fedoraproject.Config.Printing: Consumed 1.990s CPU time.

Comment 1 Jan Vlug 2019-11-17 19:26:04 UTC
Maybe this bug is a duplicate of: https://bugs.launchpad.net/hplip/+bug/1851013
I will try to test if that is really the case, and report the results here.

Comment 2 Jan Vlug 2019-11-17 19:41:46 UTC
OK, I did the test. Indeed this bug is similar as bug https://bugs.launchpad.net/hplip/+bug/1851013
I edited a line in /usr/share/hplip/data/models/models.dat as suggested.
Note that I have now this info in the file mentioned above:

[hp_colorlaserjet_mfp_m278-m281]
...
ppd-name=hp-color_laserjet_mfp_m278-m281-ps.ppd
...

Note the inconsistent use of the _ in color_laserjet and colorlaserjet

After editing the line I ran hp-setup and the printer was detected. After this, scanning via SimpleScan works as expected.

I leave it up to you to leave this bug open or to close it as duplicate of an external bug.

Comment 3 Zdenek Dohnal 2019-11-18 13:20:02 UTC
Hi Jan,

thank you for reporting the issue and I'm sorry for regression :( 

3.19.10-2+ should now have again colorlaserjetxxx entry for m278-m281 (HP should really have a standard how their printers should report themselves...)

Comment 4 Fedora Update System 2019-11-18 14:18:10 UTC
FEDORA-2019-722e4e3f0c has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-722e4e3f0c

Comment 5 Jan Vlug 2019-11-18 19:29:01 UTC
Hi Zdenek, no need to say sorry. You are always extremely helpful and responsive. Thank you!

Comment 6 Fedora Update System 2019-11-19 02:13:30 UTC
hplip-3.19.10-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-69e684dd40

Comment 7 Fedora Update System 2019-11-19 03:15:31 UTC
hplip-3.19.10-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-722e4e3f0c

Comment 8 Fedora Update System 2019-11-26 23:51:46 UTC
hplip-3.19.10-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-11-27 00:23:40 UTC
hplip-3.19.10-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.