Bug 1773372 - python-elephant fails to build with Python 3.8 on Fedora 32+
Summary: python-elephant fails to build with Python 3.8 on Fedora 32+
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-elephant
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Luis Bazan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS F32FailsToInstall PYTHON38
TreeView+ depends on / blocked
 
Reported: 2019-11-17 23:13 UTC by Miro Hrončok
Modified: 2020-01-12 01:41 UTC (History)
3 users (show)

Fixed In Version: python-elephant-0.6.4-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-12 01:41:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-11-17 23:13:35 UTC
python-elephant fails to build with Python 3.8.0b4 in Fedora 32.

See the build failures at https://koji.fedoraproject.org/koji/search?match=glob&type=package&terms=python-elephant

+ nosetests-3 -I test_unitary_event_analysis.py -I test_cubic.py
/builddir/build/BUILD/elephant-0.6.2/elephant/spike_train_generation.py:149: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if sign is 'above':
/builddir/build/BUILD/elephant-0.6.2/elephant/spike_train_generation.py:202: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if sign is 'above':
/builddir/build/BUILD/elephant-0.6.2/elephant/spectral.py:315: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if 'scaling' in params and params['scaling'] is 'spectrum':
/builddir/build/BUILD/elephant-0.6.2/elephant/signal_processing.py:369: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if filter_function is 'lfilter':
/builddir/build/BUILD/elephant-0.6.2/elephant/signal_processing.py:371: SyntaxWarning: "is" with a literal. Did you mean "=="?
  elif filter_function is 'filtfilt':
/builddir/build/BUILD/elephant-0.6.2/elephant/signal_processing.py:679: SyntaxWarning: "is" with a literal. Did you mean "=="?
  elif baseline is 'mean':
/builddir/build/BUILD/elephant-0.6.2/elephant/signal_processing.py:682: SyntaxWarning: "is" with a literal. Did you mean "=="?
  elif baseline is 'median':
/builddir/build/BUILD/elephant-0.6.2/elephant/current_source_density.py:179: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if (kwargs['f_type'] is not 'identity') and  \
/builddir/build/BUILD/elephant-0.6.2/elephant/asset.py:687: RuntimeWarning: invalid value encountered in true_divide
  AngCoeff = dY / dX
./builddir/build/BUILD/elephant-0.6.2/elephant/asset.py:687: RuntimeWarning: divide by zero encountered in true_divide
  AngCoeff = dY / dX
/builddir/build/BUILD/elephant-0.6.2/elephant/asset.py:687: RuntimeWarning: invalid value encountered in true_divide
  AngCoeff = dY / dX
/builddir/build/BUILD/elephant-0.6.2/elephant/asset.py:687: RuntimeWarning: divide by zero encountered in true_divide
  AngCoeff = dY / dX
/builddir/build/BUILD/elephant-0.6.2/elephant/asset.py:687: RuntimeWarning: invalid value encountered in true_divide
  AngCoeff = dY / dX
./builddir/build/BUILD/elephant-0.6.2/elephant/asset.py:687: RuntimeWarning: divide by zero encountered in true_divide
  AngCoeff = dY / dX
/builddir/build/BUILD/elephant-0.6.2/elephant/asset.py:687: RuntimeWarning: invalid value encountered in true_divide
  AngCoeff = dY / dX
....../builddir/build/BUILD/elephant-0.6.2/elephant/asset.py:687: RuntimeWarning: divide by zero encountered in true_divide
  AngCoeff = dY / dX
/builddir/build/BUILD/elephant-0.6.2/elephant/asset.py:687: RuntimeWarning: invalid value encountered in true_divide
  AngCoeff = dY / dX
........................................................../builddir/build/BUILD/elephant-0.6.2/elephant/current_source_density_src/utility_functions.py:47: FutureWarning: arrays to stack must be passed as a "sequence" type such as list or tuple. Support for non-sequence iterables such as generators is deprecated as of NumPy 1.16 and will raise an error in the future.
  unique_elec_pos = np.vstack({tuple(row) for row in elec_pos})
.................................S.....E.E.EE............................................................................................................../builddir/build/BUILD/elephant-0.6.2/elephant/test/test_pandas_bridge.py:48: FutureWarning: the 'labels' keyword is deprecated, use 'codes' instead
  targ = pd.MultiIndex(levels=[[6.5], [5], ['test']],
/builddir/build/BUILD/elephant-0.6.2/elephant/test/test_pandas_bridge.py:54: FutureWarning: .labels was deprecated in version 0.24.0. Use .codes instead.
  self.assertEqual(targ.labels, res0.labels)
./builddir/build/BUILD/elephant-0.6.2/elephant/test/test_pandas_bridge.py:2760: RuntimeWarning: invalid value encountered in less
  targ[targ < targ_start] = np.nan
/builddir/build/BUILD/elephant-0.6.2/elephant/test/test_pandas_bridge.py:2761: RuntimeWarning: invalid value encountered in greater
  targ[targ > targ_stop] = np.nan
../builddir/build/BUILD/elephant-0.6.2/elephant/test/test_pandas_bridge.py:2706: RuntimeWarning: invalid value encountered in less
  targ[targ < targ_start] = np.nan
./builddir/build/BUILD/elephant-0.6.2/elephant/test/test_pandas_bridge.py:2734: RuntimeWarning: invalid value encountered in greater
  targ[targ > targ_stop] = np.nan
......................................................./builddir/build/BUILD/elephant-0.6.2/elephant/test/test_signal_processing.py:209: RuntimeWarning: invalid value encountered in true_divide
  target = (signal.magnitude - m) / s
/builddir/build/BUILD/elephant-0.6.2/elephant/signal_processing.py:129: RuntimeWarning: invalid value encountered in true_divide
  (sig.magnitude - m.magnitude) / s.magnitude,
./usr/lib/python3.8/site-packages/quantities/quantity.py:321: RuntimeWarning: divide by zero encountered in true_divide
  return np.true_divide(other, self)
./builddir/build/BUILD/elephant-0.6.2/elephant/spade.py:301: UserWarning: 0<alpha<1 but p-value spectrum has not been computed (n_surr==0)
  warnings.warn('0<alpha<1 but p-value spectrum has not been '
.............................../usr/lib/python3.8/site-packages/quantities/quantity.py:321: RuntimeWarning: divide by zero encountered in true_divide
  return np.true_divide(other, self)
............/builddir/build/BUILD/elephant-0.6.2/elephant/spike_train_generation.py:335: RuntimeWarning: divide by zero encountered in true_divide
  mean_interval = 1 / rate.magnitude
......../builddir/build/BUILD/elephant-0.6.2/elephant/spike_train_generation.py:267: RuntimeWarning: invalid value encountered in sqrt
  number = np.ceil(n + 3 * np.sqrt(n))
............................/usr/lib/python3.8/site-packages/scipy/signal/spectral.py:1577: RuntimeWarning: invalid value encountered in true_divide
  Cxy = np.abs(Pxy)**2 / Pxx / Pyy
............/usr/lib/python3.8/site-packages/neo/core/basesignal.py:133: RuntimeWarning: invalid value encountered in true_divide
  new_signal = f(other, *args)
.........................../builddir/build/BUILD/elephant-0.6.2/elephant/statistics.py:256: UserWarning: Input size is too small. Please provide an input with more than 1 entry. lv returns 'NaN'since the argument `with_nan` is True
  warnings.warn("Input size is too small. Please provide "
......../builddir/build/BUILD/elephant-0.6.2/elephant/statistics.py:867: UserWarning: Instantaneous firing rate approximation contains negative values, possibly caused due to machine precision errors.
  warnings.warn("Instantaneous firing rate approximation contains "
..............................
======================================================================
ERROR: test__extract_neo_attrs__epoch_noparents_array (elephant.test.test_neo_tools.ExtractNeoAttrsTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/elephant-0.6.2/elephant/test/test_neo_tools.py", line 649, in test__extract_neo_attrs__epoch_noparents_array
    'durations': array_annotation_save['durations'],
KeyError: 'durations'
======================================================================
ERROR: test__extract_neo_attrs__epoch_parents_childfirst_array (elephant.test.test_neo_tools.ExtractNeoAttrsTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/elephant-0.6.2/elephant/test/test_neo_tools.py", line 928, in test__extract_neo_attrs__epoch_parents_childfirst_array
    'durations': array_annotation_save['durations'],
KeyError: 'durations'
======================================================================
ERROR: test__extract_neo_attrs__epoch_parents_empty_array (elephant.test.test_neo_tools.ExtractNeoAttrsTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/elephant-0.6.2/elephant/test/test_neo_tools.py", line 459, in test__extract_neo_attrs__epoch_parents_empty_array
    'durations': array_annotation_save['durations'],
KeyError: 'durations'
======================================================================
ERROR: test__extract_neo_attrs__epoch_parents_parentfirst_array (elephant.test.test_neo_tools.ExtractNeoAttrsTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/elephant-0.6.2/elephant/test/test_neo_tools.py", line 1041, in test__extract_neo_attrs__epoch_parents_parentfirst_array
    'durations': array_annotation_save['durations'],
KeyError: 'durations'
----------------------------------------------------------------------
Ran 438 tests in 528.890s
FAILED (SKIP=1, errors=4)

It is not important whether the problem is relevant to Python 3.8, this issue is blocking the Python 3.8 rebuilds.
If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32 and further.

Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Please rebuild the package in Fedora 32 (rawhide).

Let us know here if you have any questions. Thank You!

Comment 1 Miro Hrončok 2019-11-25 10:27:27 UTC
What is the plan here? Do we try to keep the package or retire it?

Comment 2 Miro Hrončok 2019-12-10 16:36:48 UTC
Please respond.

Comment 3 Ankur Sinha (FranciscoD) 2019-12-10 17:41:48 UTC
We'll work on fixing the package. There's a new release of the package. Hopefully updating to it will fix it. On our lists of todos.

Comment 4 Fedora Update System 2019-12-23 17:09:06 UTC
FEDORA-2019-4f478c7946 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4f478c7946

Comment 5 Fedora Update System 2019-12-23 17:09:25 UTC
FEDORA-2019-3a299d662e has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3a299d662e

Comment 6 Fedora Update System 2019-12-23 17:09:25 UTC
FEDORA-2019-3a299d662e has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3a299d662e

Comment 7 Fedora Update System 2020-01-04 22:23:02 UTC
python-elephant-0.6.4-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4f478c7946

Comment 8 Fedora Update System 2020-01-12 01:41:23 UTC
python-elephant-0.6.4-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.