Bug 1773375 - python-missingno fails to build with Python 3.8 on Fedora 32+
Summary: python-missingno fails to build with Python 3.8 on Fedora 32+
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-missingno
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Aniket Pradhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1773373
Blocks: F32FTBFS F32FailsToInstall PYTHON38 PYTHON39
TreeView+ depends on / blocked
 
Reported: 2019-11-17 23:16 UTC by Miro Hrončok
Modified: 2020-02-11 01:45 UTC (History)
5 users (show)

Fixed In Version: python-missingno-0.4.2-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-11 01:45:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-11-17 23:16:40 UTC
python-missingno fails to build with Python 3.8.0b4 in Fedora 32.

See the build failures at https://koji.fedoraproject.org/koji/search?match=glob&type=package&terms=python-missingno

DEBUG util.py:593:  Error: 
DEBUG util.py:593:   Problem: conflicting requests
DEBUG util.py:593:    - nothing provides python3.7dist(pandas) needed by python3-geoplot-0.2.4-3.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(matplotlib) needed by python3-geoplot-0.2.4-3.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(seaborn) needed by python3-geoplot-0.2.4-3.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(descartes) needed by python3-geoplot-0.2.4-3.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(geopandas) needed by python3-geoplot-0.2.4-3.fc31.noarch
DEBUG util.py:593:    - nothing provides python(abi) = 3.7 needed by python3-geoplot-0.2.4-3.fc31.noarch

It is not important whether the problem is caused by this package or another, this issue is blocking the Python 3.8 rebuild of this package.
If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32 and further.

Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Please rebuild the package in Fedora 32 (rawhide).

Let us know here if you have any questions. Thank You!

Comment 1 Miro Hrončok 2019-11-25 10:27:46 UTC
What is the plan here? Do we try to keep the package or retire it?

Comment 2 Ankur Sinha (FranciscoD) 2019-11-25 14:59:49 UTC
We'll keep the package. What can we do here in at the moment, though? A dep has not been built, so until the whole dep-chain is fixed this package will not be buildable/installable, right?

Comment 3 Miro Hrončok 2019-11-25 15:34:17 UTC
> A dep has not been built, so until the whole dep-chain is fixed this package will not be buildable/installable, right?

Yes. This Bugzilla was mostly opened to track the whole dep chain.

Comment 4 Ankur Sinha (FranciscoD) 2019-11-25 16:33:11 UTC
(In reply to Miro Hrončok from comment #3)
> > A dep has not been built, so until the whole dep-chain is fixed this package will not be buildable/installable, right?
> 
> Yes. This Bugzilla was mostly opened to track the whole dep chain.

OK, that's great. We'll rebuild missinginfo as soon as the deps are ready too.

Thanks,
Ankur

Comment 5 Elliott Sales de Andrade 2020-02-11 01:45:30 UTC
Sorry, didn't know there were any packages waiting on geoplot; I've gone ahead and rebuilt this one for you.


Note You need to log in before you can comment on or make changes to this bug.