Bug 177344 - URLs with commas not opened
Summary: URLs with commas not opened
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-09 21:41 UTC by Ilya Konstantinov
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 13:45:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (401 bytes, patch)
2006-01-16 23:33 UTC, Ilya Konstantinov
no flags Details | Diff

Description Ilya Konstantinov 2006-01-09 21:41:34 UTC
When Firefox is already running and XRemote is used to open the new URL, a URL
with a comma (,) will be passed to Firefox incorrectly. This is due to the
XRemote command parsing. The solution is probably to encode commas into the
relevant URL entities; same goes for spaces, which can also be mangled by XRemote.

My solution:
if [ "${USE_EXIST}" -eq "1" ] && [ "${ALREADY_RUNNING}" -eq "1" ]; then
  opt=`echo -n "$opt" | sed -e 's/,/%2c/g' -e 's/ /%20/g'`

Comment 1 Ilya Konstantinov 2006-01-16 23:33:53 UTC
Created attachment 123272 [details]
Patch

Attaching a patch to /usr/bin/firefox.

Comment 2 Ilya Konstantinov 2006-02-16 16:57:11 UTC
Christopher, are you or are you not merging in my patch?

Comment 3 Ilya Konstantinov 2006-04-19 13:45:35 UTC
This is fixed since 21 Feb 2006. Cristopher, if this is fixed in FC5 as well,
please change resolution to CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.