Bug 1773456 - [NMCI] [abrt] [faf] NetworkManager: raise(): /usr/sbin/NetworkManager killed by 6
Summary: [NMCI] [abrt] [faf] NetworkManager: raise(): /usr/sbin/NetworkManager killed ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL: http://faf.lab.eng.brq.redhat.com/faf...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-18 08:01 UTC by Vladimir Benes
Modified: 2020-04-28 16:53 UTC (History)
7 users (show)

Fixed In Version: NetworkManager-1.22.0-0.2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:53:15 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:53:41 UTC

Description Vladimir Benes 2019-11-18 08:01:38 UTC
This bug has been created based on an anonymous crash report requested by the package maintainer.

Report URL: http://faf.lab.eng.brq.redhat.com/faf/reports/bthash/9c730ac6928bf09d527835fb2e9eecee025233c8/

Comment 1 Beniamino Galvani 2019-11-18 18:05:56 UTC
 #0  raise () at /lib64/libc.so.6
 #1  abort () at /lib64/libc.so.6
 #2  n_dhcp4_client_probe_transition_t2 (ns_now=<optimized out>, probe=<optimized out>) at shared/n-dhcp4/src/n-dhcp4-c-probe.c:756
 #3  n_dhcp4_client_probe_dispatch_timer (probe=0x5612ccb4bf60, ns_now=1131240038192408) at shared/n-dhcp4/src/n-dhcp4-c-probe.c:1104
 #4  n_dhcp4_client_dispatch_timer (client=0x5612cca43fd0, client=0x5612cca43fd0, event=0x7fff11dd1300) at shared/n-dhcp4/src/n-dhcp4-client.c:573
 #5  n_dhcp4_client_dispatch (client=0x5612cca43fd0) at shared/n-dhcp4/src/n-dhcp4-client.c:629
 #6  dhcp4_event_cb (source=<optimized out>, condition=<optimized out>, data=0x5612cc953760) at src/dhcp/nm-dhcp-nettools.c:1015
 #7  g_main_context_dispatch () at /lib64/libglib-2.0.so.0
 #8  g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
 #9  g_main_loop_run () at /lib64/libglib-2.0.so.0
 #10 main (argc=<optimized out>, argv=<optimized out>) at src/main.c:451

Fix at:
https://github.com/nettools/n-dhcp4/pull/9

Comment 2 Beniamino Galvani 2019-11-18 18:25:10 UTC
Reproducer:
 - enable dhcp=nettools in NM
 - set lease time to 3 minutes on DHCP server
 - activate a DHCP connection
 - turn off the DHCP server
 - wait T2 expiration (~160 seconds), after that the assertion will fail

Comment 5 Vladimir Benes 2019-12-12 14:01:04 UTC
last seen:
    2019-11-20

Comment 7 errata-xmlrpc 2020-04-28 16:53:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.