Bug 1773489 - [ceph-ansible] - configuration of cephFS is failing when '--limit mdss' is used with site-docker.yml
Summary: [ceph-ansible] - configuration of cephFS is failing when '--limit mdss' is us...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: Ameena Suhani S H
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-18 09:45 UTC by Vasishta
Modified: 2020-01-31 12:48 UTC (History)
8 users (show)

Fixed In Version: ceph-ansible-4.0.6-1.el8cp, ceph-ansible-4.0.6-1.el7cp
Doc Type: Known Issue
Doc Text:
Cause: ceph-ansible skips certain steps when '--limit' is used and tries to execute 'ceph' commands on host instead of inside a container Consequence: ceph-ansible fails to configure cephfs when you try to configure cephfs with an already existing cluster with 'limit mdss' while running site-docker.yml Workaround (if any): Run site-docker.yml without using ''--limit mdss'' Result: ceph-ansible will run ceph commands inside the container, thus cephfs gets configured without any failure.
Clone Of:
Environment:
Last Closed: 2020-01-31 12:48:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 4749 0 'None' closed Fixes failure of cephfs configuration using --limit while running purge-docker.yml (bp #4747) 2020-04-15 22:56:42 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:48:24 UTC

Description Vasishta 2019-11-18 09:45:38 UTC
Description of problem:
 configuration of cephFS is failing when '--limit mdss' is used with site-docker.yml as container_exec_cmd is not getting formulated

Version-Release number of selected component (if applicable):
ceph-ansible-4.0.4-1

How reproducible:
Always 

Steps to Reproduce:
1. Configure a ceph containerized cluster
2. Try to add mds following the doc


Actual results:
msg: '[Errno 2] No such file or directory: ''ceph'': ''ceph'''

Expected results:
MDS must get added configuring cephFS

Additional info:

Comment 1 Vasishta 2019-11-18 10:01:27 UTC
Hi,

[1] has fixes, verified regression for configuration from scratch also
It would be nice if we can backport to stable-4.0, need to release-note otherwise.
https://github.com/ceph/ceph-ansible/pull/4747

Regards,
Vasishta 
QE, Ceph

Comment 8 errata-xmlrpc 2020-01-31 12:48:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.