Bug 1773525 - The number of saved searches in the Find & Replace dialog does not change from default of 10 when edited.
Summary: The number of saved searches in the Find & Replace dialog does not change fro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-18 11:08 UTC by Bill Sanford
Modified: 2019-11-23 01:30 UTC (History)
7 users (show)

Fixed In Version: libreoffice-6.3.3.2-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-23 01:30:58 UTC


Attachments (Terms of Use)

Description Bill Sanford 2019-11-18 11:08:14 UTC
Description of problem:
The number of saved searches in the Find & Replace dialog does not change from default of 10 when edited. 

In https://wiki.documentfoundation.org/ReleaseNotes/6.3:

The number of saved searches in the Find & Replace dialog can be adjusted per expert configuration Tools ▸ Options ▸ LibreOffice ▸ Advanced org::openoffice::Office::Common::Misc::FindReplaceRememberedSearches tdf#122322 

Version-Release number of selected component (if applicable):
RHEL-8.1.0-20191015.0
LO 6.3.3.2

How reproducible:
100% 

I have seen this on F30, as well.

Steps to Reproduce:

1. Tools -> Options -> LibreOffice -> Advanced -> Open Expert Configuration button
2. Look for org.openoffice.Office.Common.Misc.FindReplaceRememberedSearches
NOTE: org.openoffice.Office.Common is in the first part of the list and you need to open this value and drill down on Misc and the Find value.
3. Double click the value to change it.
4. Change to a different value than the default of 10, click OK and OK, again.
5. Click Apply to save changes
6. Use CTRL-F or the toobar to search for search1, search2, etc. 

I could start this in Calc and open Writer and see the same results.

Actual results:
The number of saved searches in the Find & Replace dialog does not change from default of 10 when edited.

Expected results:
The number of saved searches in the Find & Replace dialog does change from default of 10 when edited to the new number that was saved.

Additional info:

Comment 1 Caolan McNamara 2019-11-18 11:37:05 UTC
This is filed against RHEL-8 and mentions "RHEL-8.1.0-20191015.0 and LO 6.3.3.2", but RHEL-8 only has LibreOffice 6.0.6 currently which doesn't have the feature or configuration element mentioned in the 6.3 release notes.

In Fedora 30 if I make the number larger then it seems to do the right thing, but doesn't seem to do the right thing if I *reduce* the number

Comment 2 Bill Sanford 2019-11-18 12:15:32 UTC
I have installed LO 6.0 and 6.3 on a RHEL 8.1.0 system. I did see that 6.0 had the functionality missing. I am adding 6.3 test cases to the LO test plan based on the release notes that are public in the original post. I guess I was just trying to get ahead of the testing and finding bugs earlier so that when the RHEL release supports => LO 6.3, this will be a non-issue.

Comment 3 Caolan McNamara 2019-11-18 12:35:37 UTC
There's definitely something a little whacky about this, looks to me that the wrong candidates are also rotated out of the list when it hits the max

Comment 4 Bill Sanford 2019-11-18 12:39:11 UTC
I wasn't sure how it was supposed to show relevant results and glad you caught it.

Comment 5 Caolan McNamara 2019-11-18 12:51:43 UTC
https://gerrit.libreoffice.org/#/c/83088/ for problem that setting a lower amount to save didn't do anything

Comment 6 Bill Sanford 2019-11-18 12:54:46 UTC
I would also look for a higher value, too. When I tested it, I set the # to 20 and could only get 10 and when I went over 10, the first searches were popped off the list.

Comment 7 Caolan McNamara 2019-11-18 13:48:21 UTC
https://gerrit.libreoffice.org/#/c/83094/ for the issue that the wrong elements are removed when the limit is hit

Comment 8 Caolan McNamara 2019-11-18 14:11:39 UTC
The fixes are upstream now in upstream master and proposed for upstream 6-3. Also included in F31, which has 6.3 (while F30 has 6.2 which doesn't have the feature).

I'm not sure how to proceed with this bug because the feature doesn't exist in RHEL-8 in order to be fixed there. Move this to Fedora 31 ?, or dev-nack it for RHEL ?

Comment 9 Bill Sanford 2019-11-18 14:36:30 UTC
Yeah, I will move it to F31.

Comment 10 Fedora Update System 2019-11-19 09:03:09 UTC
FEDORA-2019-fb7333e52b has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-fb7333e52b

Comment 11 Fedora Update System 2019-11-20 01:27:47 UTC
libreoffice-6.3.3.2-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-fb7333e52b

Comment 12 Fedora Update System 2019-11-23 01:30:58 UTC
libreoffice-6.3.3.2-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.