Bug 1773563 - replicaCount value differs for "volume info" and "volume info --xml" (clone of bug 1773518 )
Summary: replicaCount value differs for "volume info" and "volume info --xml" (clone o...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sanju
QA Contact:
URL:
Whiteboard:
: 1773518 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-18 13:16 UTC by Omar K
Modified: 2020-01-29 07:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1773518
Environment:
Last Closed: 2020-01-29 07:51:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 23718 0 None Abandoned cli: exclude arbiter bricks from replicaCount in \"vo info --xml\" output 2020-04-28 19:30:28 UTC

Description Omar K 2019-11-18 13:16:10 UTC
+++ This bug was initially created as a clone of Bug #1773518 +++

Description of problem:

The "gluster volume info VOLNAME --xml" differs from the "gluster volume info VOLNAME" output where the replicaCount is concerned. In the first case replicaCount includes the arbiter bricks whereas in the second case it does not.

The correct behaviour should be to exclude the arbiter bricks from replicaCount because that is the way it is done with "gluster volume create" as well.


XML Output:

<brickCount>3</brickCount>
<distCount>3</distCount>
<stripeCount>1</stripeCount>
<replicaCount>3</replicaCount>
<arbiterCount>1</arbiterCount>


regular output:

Number of Bricks: 1 x (2 + 1) = 3

--- Additional comment from Worker Ant on 2019-11-18 10:44:21 UTC ---

REVIEW: https://review.gluster.org/23718 (Exclude arbiter bricks from replicaCount in \"volume info --xml\" output) posted (#1) for review on master by Omar Kohl

Comment 1 Worker Ant 2019-11-18 13:48:21 UTC
REVIEW: https://review.gluster.org/23718 (Exclude arbiter bricks from replicaCount in \"volume info --xml\" output) posted (#2) for review on master by Omar Kohl

Comment 2 Sanju 2020-01-09 08:04:56 UTC
*** Bug 1773518 has been marked as a duplicate of this bug. ***

Comment 3 Sanju 2020-01-29 07:51:08 UTC
As this can break backward compatibility, closing this bug as won't fix.

Thanks,
Sanju


Note You need to log in before you can comment on or make changes to this bug.