Bug 177367 - Allow building with alternative JDK
Summary: Allow building with alternative JDK
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-10 03:17 UTC by Kenneth Porter
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.3.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 14:29:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reduces specification of JDK allowing alternative suppliers (703 bytes, patch)
2006-01-10 03:17 UTC, Kenneth Porter
no flags Details | Diff

Description Kenneth Porter 2006-01-10 03:17:10 UTC
Instead of hard-coding gcj in the spec file, use the "alternatives" feature. I'm
attaching a patch for the spec file which changes two lines: The path to the
JDK, and the BuildRequires for the JDK version. These reduce the specificity to
allow use of Sun and other Java suppliers.

An additional upstream issue is that the JNI headers are located with a find
command that fails to find all include subdirectories, due to the use of
symbolic links. I've just raised this issue on the subversion-devel mailing list
to get upstream input. I'll append more info on that once the developers respond.

Comment 1 Kenneth Porter 2006-01-10 03:17:11 UTC
Created attachment 122983 [details]
Reduces specification of JDK allowing alternative suppliers

Comment 2 Kenneth Porter 2006-01-10 19:27:16 UTC
My post to the subversion-devel list about the JNI headers issue:

http://permalink.gmane.org/gmane.comp.version-control.subversion.devel/71849

No response at this time.

Comment 3 Joe Orton 2006-01-31 14:29:18 UTC
I've applied the patch to relax the requirements; thanks.


Note You need to log in before you can comment on or make changes to this bug.