Bug 1773686 - Installer Panic When Trying to Gather logs in Private Clusters
Summary: Installer Panic When Trying to Gather logs in Private Clusters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Patrick Dillon
QA Contact: Gaoyun Pei
URL:
Whiteboard:
: 1773687 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-18 17:49 UTC by Patrick Dillon
Modified: 2020-01-23 11:13 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:13:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 2684 0 'None' closed Bug 1773686: GCP Gather: use bootstrap internal ip when missing external 2021-02-10 05:52:42 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:13:26 UTC

Comment 1 Scott Dodson 2019-11-18 18:24:23 UTC
*** Bug 1773687 has been marked as a duplicate of this bug. ***

Comment 4 Gaoyun Pei 2019-11-22 07:41:05 UTC
Verify this bug with 4.3.0-0.nightly-2019-11-21-230534.

# ./openshift-install version
./openshift-install v4.3.0
built from commit a702fd4beb593932067fe1b31f2d911feaa6d93e
release image registry.svc.ci.openshift.org/ocp/release@sha256:15132234d0b753aea0af00f5cfff429cf5eca57513e7cce530207b05167a999f


Install a private cluster out of the cluster VPC, no panics when trying to gather logs.

# ./openshift-install create cluster --dir gpei-2
INFO Consuming Install Config from target directory 
INFO Creating infrastructure resources...         
INFO Waiting up to 30m0s for the Kubernetes API at https://api.gpei-2.qe.gcp.devcluster.openshift.com:6443... 
ERROR Attempted to gather ClusterOperator status after installation failure: listing ClusterOperator objects: Get https://api.gpei-2.qe.gcp.devcluster.openshift.com:6443/apis/config.openshift.io/v1/clusteroperators: dial tcp: lookup api.gpei-2.qe.gcp.devcluster.openshift.com on 10.11.5.19:53: no such host 
INFO Pulling debug logs from the bootstrap machine 
ERROR Attempted to gather debug logs after installation failure: failed to create SSH client, ensure the proper ssh key is in your keyring or specify with --key: ssh: handshake failed: ssh: unable to authenticate, attempted methods [none publickey], no supported methods remain 
FATAL Bootstrap failed to complete: waiting for Kubernetes API: context deadline exceeded

Comment 6 errata-xmlrpc 2020-01-23 11:13:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.