Bug 177371 - need Kannada inscript and kgp maps
need Kannada inscript and kgp maps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: m17n-db (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mayank Jain
: FutureFeature, i18n
Depends On:
Blocks: Indic 209963
  Show dependency treegraph
 
Reported: 2006-01-09 23:55 EST by Jens Petersen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: m17n-db-kannada-1.3.3-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 07:45:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2006-01-09 23:55:31 EST
Description of problem:
An inscript map for Kannada needs to be added.

Additional info:
There is one in scim-tables ported from iiimf-unitle.
Comment 1 Jens Petersen 2006-02-22 05:23:44 EST
Maps have been ported.
Comment 2 Satyabrata Maitra 2006-03-14 01:20:01 EST
Tested on : m17n-db-kannada-1.3.3-1.
Inscript keymap is imported and appearing properly.
Keymap table is as per the Government standard.
Test performed on gedit.
Comment 3 Satyabrata Maitra 2006-03-14 04:58:51 EST
Tested on : m17n-db-kannada-1.3.3-1.
kgp maps is ported and appearing properly.
Z and X is not showing the proper character as shown in the printed  keyboard
layout.

Website followed : http://brahmi.sourceforge.net/images/KGP-KB-layout.JPG
Comment 4 Jens Petersen 2006-03-14 05:53:14 EST
Are you able to write here the characters that should be on Z and X ?
Comment 5 Satyabrata Maitra 2006-03-17 08:19:07 EST
I will update the bug with the unicode next week after the research.
Comment 6 Jens Petersen 2006-03-17 08:54:08 EST
Ok, thanks.  Let's leave it in Assigned until the fix is made.
Comment 7 Lawrence Lim 2006-10-03 02:52:30 EDT
Ramki, 
Would you be able to help with your language background?
Comment 8 Ramakrishna Reddy Yekulla 2006-10-06 14:22:13 EDT
Hi all
Firstly KGP has nothing to do with Inscript, its another input method, but a
very important one, its a very important standard by the local govt. In the
above perticular case the Key isn't mapped, in the keymaps of kgp . 
o The character Z must be mapped to ಙ UOC99.
o both x and X [SHIFT + x] is mapped wrongly.
### IMPORTANT
Additionally I have observed the following mistakes in the scim-kannada-kgp 
o [SHIFT + h ] H is appering as H, instead of ಃ U0C83
o Wrong map found at s , appears as ಷ instead of ಸ UOCB8. 
Comment 10 Mayank Jain 2006-11-06 06:54:21 EST
Since this is fixed in current release for devel branch, moving to modified for
QE to test.
Comment 11 Mayank Jain 2006-11-14 07:07:05 EST
Comment #18 From Ramakrishna Reddy (rreddy@redhat.com) 	 on 2006-11-14 06:26 EST  	

In KGP it is as follows ::
o  0C95 0CCD 0CB7  for Shift + X 
o  X is 0CB7 ಷ
Comment 12 Mayank Jain 2006-11-14 07:08:00 EST
Based on Comment 11, changing it back to assigned state.
Comment 13 Mayank Jain 2006-11-14 08:05:49 EST
Fixed in 

----------------------------------------  --------------------  ----------------
m17n-db-1.3.3-38.fc7                      dist-fc7              majain
m17n-db-1.3.3-36.fc6                      dist-fc6-updates-candidate  majain
Comment 14 A S Alam 2007-03-15 07:45:32 EDT
it is fixed with issued as mention
tested with following packages:
m17n-db-1.3.4-7.fc7

Note You need to log in before you can comment on or make changes to this bug.