Bug 1773733 - Install plan components of same type use same key resulting in console error
Summary: Install plan components of same type use same key resulting in console error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.3.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-18 20:02 UTC by Robb Hamilton
Modified: 2020-01-23 11:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.3.0-0.ci-2019-11-17-192542 Cluster ID: c1fd1b31-9154-4f09-90ff-2a6ccd854597
Last Closed: 2020-01-23 11:13:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
Install Plan > Components console error (453.83 KB, image/png)
2019-11-18 20:02 UTC, Robb Hamilton
no flags Details
There is no console error now (228.42 KB, image/png)
2019-11-22 02:43 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3456 'None' 'open' 'Bug 1773733: add specificity to Istall Plan > Component key' 2019-11-18 20:36:18 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:13:37 UTC

Description Robb Hamilton 2019-11-18 20:02:10 UTC
Created attachment 1637381 [details]
Install Plan > Components console error

Description of problem:  A browser console error occurs when visiting Install Plan > Components page when there are two or more components of the same type (e.g., CustomResourceDefinition)

Steps to Reproduce:
1.  Install etcd operator
2.  Visit k8s/ns/<NAMESPACE>/operators.coreos.com~v1alpha1~InstallPlan/install-btvc4/components
3.  Note the browser console error

Actual results:  A browser console error is present.


Expected results:  No browser console error occurs.


Additional info:  see attached screenshot.

Comment 2 XiaochuanWang 2019-11-22 02:43:13 UTC
Created attachment 1638621 [details]
There is no console error now

Comment 3 XiaochuanWang 2019-11-22 02:44:04 UTC
Refer to the attachment for screenshot.
This is fixed.
Verified on 4.3.0-0.nightly-2019-11-21-122827

Comment 5 errata-xmlrpc 2020-01-23 11:13:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.