Bug 177378 - need Malayalam inscript map
need Malayalam inscript map
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: m17n-db (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mayank Jain
: FutureFeature, i18n
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2006-01-10 01:06 EST by Jens Petersen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: m17n-db-malayalam-1.3.3-3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-29 06:18:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2006-01-10 01:06:30 EST
Description of problem:
An inscript Malayalam map needs to be added.

Additional info:
There is one in scim-tables ported from iiimf-unitle.

There are also typewriter layouts at:
http://indlinux.sourceforge.net/images/keymap/typ/
Comment 1 Jens Petersen 2006-02-22 05:21:44 EST
Inscript map has been added.  Is a phonetic one needed?  Exists?
Comment 2 Ani Peter 2006-03-14 03:01:49 EST
Malayalam inscript map does not match with th inscript found in the following link

http://malayalamlinux.sourceforge.net/input-methods/ml_inscript_layout.jpg

The inscript in the link is proposed by the Govt of kerala, it says. If this is
the correct inscript layout that is used and exists in the state, the Redhat
standards must be changed accordingly. Thus we can improve on our product and
make it useful for our people. We must find the existing keyboard layout and use
them.
Comment 3 Ani Peter 2006-03-14 05:20:56 EST
Input method for malayalam not working in kedit when logged in with the default
language as malayalam. But if log in using any other Indic laguages both kedit
and gedit works ok. display of fonts malayalam are fine. Problem is in the input
method alone.
Comment 4 Jens Petersen 2006-03-14 07:07:51 EST
Following up after long private conversation on irc.

In reply to comment 2:

Can you help to fix the ml-inscript.mim input map according to the Kerala
standard?  Probably aalam or Runa can help with that if necessary. :)

Comment3:
I think this is because the ml_IN locale is not defined yet.
Comment 5 Ani Peter 2006-03-24 01:36:18 EST
have edited the ml-inscript.mim given my majain. all alphabets that are present
in the unicode chart (http://www.unicode.org/)have been mapped in the inscript
file.But a key called "NUKTA" that is present in the inscript keylayout does not
have unicode in malayalam, according to the unicode chart. Being an unavoidable
character, as it is necessary to form the chillu combinations in malayalam, I
have used the unicode of "NUKTA" from the devanagari unicode chart. Runa, says
the "NUKTA" is borrowed from devanagari for the bangali language too. 

Also at present "NUKTA" doesnt work with SCIM on FC5 , but using setkb it works
fine.
Comment 6 Mayank Jain 2006-03-24 01:41:35 EST
(In reply to comment #3)
> Input method for malayalam not working in kedit when logged in with the default
> language as malayalam. But if log in using any other Indic laguages both kedit
> and gedit works ok. display of fonts malayalam are fine. Problem is in the input
> method alone.
> 

This issue is resolved in FC5. Malayalam keymap (scim) works when logged in
gnome with malayalam as language.
Comment 7 Mayank Jain 2006-05-12 08:37:15 EDT
Malayalam keymaps (the latest ones) work fine in FC5.
m17n-db-malayalam-1.3.3-2

Note You need to log in before you can comment on or make changes to this bug.