Bug 17738 - Cannot upgrade imlib
Cannot upgrade imlib
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: imlib (Show other bugs)
6.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: David Mason
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-20 00:46 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-20 00:46:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-20 00:46:42 EDT
It started last night when I was trying to upgrade XFree & Enlightment.  I
removed so much only to find the initial problem was a library path that
nothing worked.  I performed a full Upgrade (minus the kernel) from the
Linux 6.2 disc I bought tonight.  XFree works again, but Enlightenment is
hung.

I started by trying to upgrade to enlightenment-1.6 (since v1.5 isn't even
working now).  RPM said I needed imlib >= 1.9.8.  I found the latest at
your mirror
ftp://ftp.cs.wisc.edu/pub/mirrors/linux/redhat-rawhide/SRPMS/SRPMS/.  When
I went to install it, I received:
     only packages with major numbers <= 3 are supported by this version of
RPM
     error: imlib-1.9.8.1-1.src.rpm cannot be installed

Please tell me what steps I need to take to either get around this error in
RPM or how to upgrade RPM to accept more major numbers.  (I cannot upgrade
RPM to 3.0.6 for the same reason - major numbers).  Thanks for your time &
help.
Comment 1 David Mason 2000-09-20 21:33:20 EDT
This is because the new package was built with RPM 4.0 - You are trying to
install a package that is built for the next release of Red Hat (very soon now).
You will need to install one of the public betas to get all the support you need
(glibc, etc)... but you can upgrade your RPM from the errata page for 6.2 to
version 3.0.5 which supports RPMs built with 4.0 and install the SRPM and build
it for your 6.2 system. Your easiest method for the new E is to wait for the
next release and grab it or purchase it - many things have changed and it will
be out very soon.

Note You need to log in before you can comment on or make changes to this bug.