Bug 177384 - Burning a DVD ends with a growisofs error message.
Burning a DVD ends with a growisofs error message.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 02:55 EST by Robin Laing
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 11:59:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Laing 2006-01-10 02:55:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
If I burn a DVD (data or video project), the burn process stops with a growisofs error message.  If I burn an image to the HD and then burn the DVD with the ISO, there is no error message.  3 different FC 4 machines.

Version-Release number of selected component (if applicable):
k3b-0.12.10-0.fc4.1

How reproducible:
Always

Steps to Reproduce:
1.Open k3b
2.Select new DVD project
3.Select files and drag to the project window.
4.Click burn
5.Set parameters as necessary.  I use the defaults.

Actual Results:  DVD burns as expected until I believe the fixating stage.  At this stage, the error message occurs.  I say this as the files seem to be on the DVD but the DVD (video) won't load on a DVD player.

Expected Results:  The process should end with a success.

Additional info:

This has occured since December 23, the first time I saw it.  I didn't try a DVD burn until over Xmas and that was my first DL disk on a different machine.  Same error.  Tonight I tried a third machine with the same error.

If I follow the same procedures but only burn the iso, all seems to work well.

To me this is a high severity as I cannot trust my data backups done via k3b to DVD.  It also prevents me from doing work in an effecient way.
Comment 1 Harald Hoyer 2006-01-10 05:40:49 EST
what is the error message?
Comment 2 Robin Laing 2006-01-13 03:53:47 EST
It isn't as bad as it was.  One of the updates fixed most of the problems.  I
did some tests and had no problems, yet.  The day I posted the bug report, I had
wasted a couple of DVD's when I got the same error as below.

Tonight I ended up with the error again but only with DL media.

In the k3b display screen.

Writing {some other stuff}
Flushing the cache may take some time.
growisofs did not exit cleanly.  <  This is all there was for an error message.

From the k3b lastlog. (tail)

/dev/scd0 flushing cache
/dev/scd0 closing track
/dev/scd0 closing session.

This was on a computer that I had just burned a good data disk.
This was a video disk and dual layer.

Now I noticed this and didn't think anything of it before.

The blank DL disk did read properly if I read the data via the recorder details
in the k3b display.  But the graph on the bottom didn't work properly.  It was
displaying red for the .3 gig over the single layer size.  It had a limit of 4.4
gig as normal when it should have been 8.5Gig.  I don't know if this has
anything to do with it.


The machine was not being used for anything else at the time of the burn.

I am going to try a recording on the third computer and see what happens.
Comment 3 Robin Laing 2006-02-01 01:54:24 EST
Well it happened on a computer that I thought was working great.

After burning a number of CD's last night and some DATA DVD's tonight, I went to
burn a Video Project and ended up with the same error.

growisofs did not exit cleanly.


This is the info from the k3b lastlog.

[System] K3b Version: 0.12.10
[System] KDE Version: 3.5.0-0.4.fc4 Red Hat
[System] QT Version:  3.3.4
[System] Kernel:      2.6.14-1.1656_FC4
[Devices] HL-DT-ST DVD-ROM GDR8162B 0015 (/dev/hdd, ) at /media/cdrom [CD-ROM;
DVD-ROM] [DVD-ROM; CD-ROM] [None]
[Devices] HL-DT-ST DVDRAM GSA-4040B A300 (/dev/hdc, ) at /media/cdrecorder
[CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-RAM; DVD-R; DVD-RW; DVD+R; DVD+RW] [DVD-ROM;
DVD-R Sequential; DVD-RAM; DVD-RW Restricted Overwrite; DVD-RW Sequential;
DVD+RW; DVD+R; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16;
RAW/R96P; RAW/R96R; Restricted Overwrite]
[Used versions] growisofs: 5.21
[Used versions] mkisofs: 2.1
[growisofs command:] /usr/bin/growisofs -Z /dev/hdc -use-the-force-luke=notray
-use-the-force-luke=tty -speed=2 -gui -graft-points -volid Screwples -volset 
-appid K3B THE CD KREATOR (C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM
-publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort
/tmp/kde-robin/k3blJPYqb.tmp -rational-rock -hide-list
/tmp/kde-robin/k3beesZHa.tmp -joliet -hide-joliet-list
/tmp/kde-robin/k3bvK6egb.tmp -full-iso9660-filenames -iso-level 2 -path-list
/tmp/kde-robin/k3b8XjyCb.tmp
[growisofs] INFO: UTF-8 character encoding detected by locale settings.
[growisofs]  Assuming UTF-8 encoded filenames on source filesystem,
[growisofs]  use -input-charset to override.
[growisofs] /dev/hdc: "Current Write Speed" is 2.0x1385KBps.
[growisofs]   0.05% done, estimate finish Wed Feb  1 03:24:57 2006
[growisofs]   0.10% done, estimate finish Wed Feb  1 01:26:06 2006
[growisofs]   0.15% done, estimate finish Wed Feb  1 00:59:03 2006
[growisofs]   0.20% done, estimate finish Wed Feb  1 00:37:02 2006

.....

[growisofs]  99.63% done, estimate finish Tue Jan 31 23:43:07 2006
[growisofs]  99.68% done, estimate finish Tue Jan 31 23:43:08 2006
[growisofs]  99.73% done, estimate finish Tue Jan 31 23:43:08 2006
[growisofs]  99.77% done, estimate finish Tue Jan 31 23:43:08 2006
[growisofs]  99.82% done, estimate finish Tue Jan 31 23:43:08 2006
[growisofs]  99.88% done, estimate finish Tue Jan 31 23:43:07 2006
[growisofs]  99.92% done, estimate finish Tue Jan 31 23:43:08 2006
[growisofs]  99.97% done, estimate finish Tue Jan 31 23:43:08 2006
[growisofs] Total translation table size: 0
[growisofs] Total rockridge attributes bytes: 2445
[growisofs] Total directory bytes: 6144
[growisofs] Path table size(bytes): 42
[growisofs] Max brk space used 0
[growisofs] 1006772 extents written (1966 MB)
[growisofs] /dev/hdc: flushing cache
[growisofs] /dev/hdc: updating RMA
[growisofs] /dev/hdc: closing session

The DVD is not playable in a normal DVD player but will play on the computer.
Comment 4 Robin 2006-03-14 11:52:26 EST
As of last night, this issue is still a problem and has not been fixed.

Two things came up on the Fedora users mail list.

One is character sets that are default in mkisofs.  I know that my latest
failure was not related to this as I can make an ISO image using k3b and then
burn the image.  Even using the same files/directories that failed without the
image step.

The other is that this problem does not occur in the latest k3b.

Could it be this easy to fix?
---------------------
Yes mine is later, I'm using 0.12.12. I installed the SRPM for k3b,
downloaded the latest k3b from the k3b website and updated the spec file
for 0.12.12 and recompiled it.
---------------------
Comment 5 Robin Laing 2006-03-23 00:39:47 EST
Saw that there was a new K3B in Fedora Testing and I downloaded it.  Burnt a
SL-DVD tonight and all went well.  No errors and the burn worked.  I am happy.

k3b-0.12.14-0.FC4.1

I will install it on my other computers and test it there.
Comment 6 Robin Laing 2006-03-24 02:59:58 EST
Well I trusted K3B and it did burn the video projects but the DVD's wouldn't
play in my DVD player.  There is still a problem.

The old version would make a working ISO and then I could burn the ISO.  I will
try that tomorrow.

From the k3b last log.

[growisofs command:] /usr/bin/growisofs -Z /dev/hdc -use-the-force-luke=notray
-use-the-force-luke=tty -speed=2 -gui -graft-points -volid xxxxxxx -volset
 -appid K3B THE CD KREATOR (C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM
-publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort
/tmp/kde-xxxxxx/k3bwqL2Wa.tmp -rational-rock -hide-list
/tmp/kde-xxxxxx/k3bxq9ZLa.tmp -joliet -hide-joliet-list
/tmp/kde-xxxxxx/k3bX9YHtc.tmp -full-iso9660-filenames -iso-level 2 -path-list
/tmp/kde-xxxxxx/k3bNo1Lnc.tmp

Looks like it may be missing the "-dvd-compat" command when making a Video DVD
project.

Comment 7 Robin Laing 2006-03-24 16:45:25 EST
Well, I did a test and I can still use k3b to make an image and burn the image
to a DVD with no problems.  This will play in my DVD player.

Note You need to log in before you can comment on or make changes to this bug.