Bug 1773851 - ceph-ansible is failing for rolling upgrade from ceph 3.3z1 to ceph 4.0
Summary: ceph-ansible is failing for rolling upgrade from ceph 3.3z1 to ceph 4.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: Uday kurundwade
URL:
Whiteboard:
Depends On:
Blocks: 1750994
TreeView+ depends on / blocked
 
Reported: 2019-11-19 06:04 UTC by Uday kurundwade
Modified: 2020-01-31 12:48 UTC (History)
10 users (show)

Fixed In Version: ceph-ansible-4.0.5-1.el8cp, ceph-ansible-4.0.5-1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:48:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 4694 0 'None' closed update: add default values when setting fact (bp #4692) 2020-03-01 10:40:00 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:48:24 UTC

Description Uday kurundwade 2019-11-19 06:04:46 UTC
Description of problem:
ceph-ansible is failing for rolling upgrade from ceph 3.3z1 to ceph 4.0

Version-Release number of selected component (if applicable):
ansible-2.8.6-1.el7ae.noarch
ceph-ansible-4.0.4-1.el7cp.noarch

How reproducible:
Always

Steps to Reproduce:
1.Deploy 3.3z1 cluster
2.Run rolling upgrade for ceph 4.0

Actual results:
Upgrade is failing for mds since there is no mds in cluster

TASK [set_fact mds_active_name] **************************************************************************************************************************************************************************************************************
Monday 18 November 2019  19:22:24 +0000 (0:00:00.049)       9:49:18.162 *******
fatal: [f10-h29-b07-5039ms]: FAILED! =>
  msg: 'Unexpected templating type error occurred on ({{ (_mds_active_name.stdout | from_json).filesystems[0][''mdsmap''][''info''] }}): expected string or buffer'


Expected results:
It should not look for mds if it is not there in inventory file

Additional info:

Comment 8 errata-xmlrpc 2020-01-31 12:48:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.