Bug 1773909 - [IPI][Openstack] First attempt to destroy cluster sometimes fails with msg="Resource not found"
Summary: [IPI][Openstack] First attempt to destroy cluster sometimes fails with msg="R...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.2.z
Assignee: Mike Fedosin
QA Contact: David Sanz
URL:
Whiteboard:
Depends On: 1772477
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-19 10:04 UTC by Martin André
Modified: 2019-12-11 22:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1772477
Environment:
Last Closed: 2019-12-11 22:36:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 2701 0 'None' 'open' 'Bug 1773909: OpenStack: Fix destroy module' 2019-12-02 12:55:40 UTC
Red Hat Product Errata RHBA-2019:4093 0 None None None 2019-12-11 22:36:21 UTC

Description Martin André 2019-11-19 10:04:22 UTC
+++ This bug was initially created as a clone of Bug #1772477 +++

Description of problem:
First attempt to destroy cluster in OpenStack sometimes fail with:
level=fatal msg="Resource not found"
Second attempt works fine and the cluster is removed.

Following error is shown:
level=debug msg="Deleting Floating IP: d1f931dd-6df1-4f56-ae0c-8095d64e5a7a"
level=fatal msg="Resource not found"


Version-Release number of the following components:
OCP 4.2.2

How reproducible:
Sometimes

Steps to Reproduce:
1. Install OCP 4.2.2 in OpenStack: openshift-install --log-level debug create cluster --dir /home/jenkins/workspace/install-ocp4-2-plus/openshift/cluster-installation/psi/fbr-42-t1
2. wait for installation to finish
3. try to destroy the cluster: openshift-install --log-level debug destroy cluster --dir /home/jenkins/workspace/destroy-ocp4-2-plus/openshift/cluster-installation/psi/fbr-42-t1

Actual results:
Removal fails.
Full logs attached but here is the error msg:
level=debug msg="Deleting Floating IP: d1f931dd-6df1-4f56-ae0c-8095d64e5a7a"
level=fatal msg="Resource not found"

Expected results:
Cluster is removed without any errors.

Additional info:
Also saw following error from different cluster:
level=debug msg="Deleting container: ocp-jqe2-lzc2g-image-registry-ptmfjgligviifudscepaghxhcthtggmu\n"
level=fatal msg="Resource not found"

I don't know if the err:
level=fatal msg="Resource not found" 
is related to previous message:
level=debug msg="Deleting Floating IP: d1f931dd-6df1-4f56-ae0c-8095d64e5a7a"
but if yes, I can see in install log that this IP was created by installer:
level=debug msg="module.topology.openstack_networking_floatingip_associate_v2.api_fip[0]: Creation complete after 5s [id=d1f931dd-6df1-4f56-ae0c-8095d64e5a7a]"

Full debug log from installation, from failed removal and from second successful removal are attached. Installation dir is attached too.

--- Additional comment from Filip Brychta on 2019-11-14 13:49:01 CET ---



--- Additional comment from Filip Brychta on 2019-11-14 13:49:29 CET ---



--- Additional comment from Filip Brychta on 2019-11-14 13:50:09 CET ---



--- Additional comment from Martin André on 2019-11-18 15:53:04 CET ---

We've fixed a number of issues with the destroy command on Openstack platform in the master branch and I'm confident this is fixed in the 4.3 builds. We should consider backporting those fixes to 4.2.z.

--- Additional comment from Martin André on 2019-11-18 15:57:11 CET ---



--- Additional comment from Martin André on 2019-11-18 16:45:55 CET ---

This should have been fixed with https://github.com/openshift/installer/pull/2408

Targeting the bug to 4.3.0 so that QE can confirm the issue is fixed and we'll backport to 4.2.z after cloning the BZ.

Comment 3 David Sanz 2019-12-04 09:09:00 UTC
Verified on 4.2.0-0.nightly-2019-12-04-081458

Comment 5 errata-xmlrpc 2019-12-11 22:36:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4093


Note You need to log in before you can comment on or make changes to this bug.