Bug 1774078 - incorrect linuxptp image name in ptp-operator hack/env.sh
Summary: incorrect linuxptp image name in ptp-operator hack/env.sh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: zenghui.shi
QA Contact: huirwang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-19 14:13 UTC by zenghui.shi
Modified: 2020-05-13 21:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:52:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ptp-operator pull 19 0 'None' closed BUG 1774078: fix env var name 2020-04-17 09:34:07 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:52:55 UTC

Description zenghui.shi 2019-11-19 14:13:24 UTC
Description of problem:

In ptp-operator repo, hack/env.sh, LINUXPTP_DAEMON_IMAGE_DIGEST env var is incorrectly reference when generating LINUX_DAEMON_IMAGE name. This leads to operator deployment failure when runs locally. (since hack/env.sh is only used when deploying operator locally, this will not impact user who deploys operator via openshift marketplace)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 zenghui.shi 2019-12-06 03:52:33 UTC
hack/env.sh is only used when doing local deployment, it doesn't affect ptp is deployed in production. moving this to 4.4

Comment 4 errata-xmlrpc 2020-05-13 21:52:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.