Bug 1774103 - The '--delete' option when used with reposync command deletes the packages immediately after download.
Summary: The '--delete' option when used with reposync command deletes the packages im...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf-plugins-core
Version: 8.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.0
Assignee: Marek Blaha
QA Contact: Jan Blazek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-19 15:17 UTC by Abhijeet Joshi
Modified: 2020-04-28 16:49 UTC (History)
5 users (show)

Fixed In Version: dnf-plugins-core-4.0.12-2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:49:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:49:17 UTC

Description Abhijeet Joshi 2019-11-19 15:17:45 UTC
Description of problem:
* The '--delete' option if used with reposync command immediately deletes the packages after download which it should not.


Scenario 1: If only 1 repo is used:

The packages are getting downloaded properly and not deleted.
---------------------------------------------------------------------
[root@rhel8 pub]# dnf reposync -p /var/ftp/pub/ --delete --download-metadata -n -m --repo=ansible-2-for-rhel-8-x86_64-rpms
Updating Subscription Management repositories.
Red Hat Ansible Engine 2 for RHEL 8 x86_64 (RPM  12 kB/s | 4.0 kB     00:00    
Modular dependency problems:

 Problem 1: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBD-SQLite:1.58:8010020190322125518:073fa5fe-0.x86_64
 Problem 2: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBI:1.641:8010020190322130042:16b3ab4d-0.x86_64
Red Hat Ansible Engine 2 for RHEL 8 x86_64 (RPM 147 kB/s | 1.0 MB     00:06    
comps.xml for repository ansible-2-for-rhel-8-x86_64-rpms saved
(1/3): ansible-test-2.9.0-2.el8.noarch.rpm      889 kB/s | 430 kB     00:00    
(2/3): ansible-2.9.0-2.el8.noarch.rpm            12 MB/s |  17 MB     00:01    
(3/3): sshpass-1.06-3.el8ae.x86_64.rpm          7.1 kB/s |  27 kB     00:03 
---------------------------------------------------------------------


Scenario 2: When multiple repos are used:

The packages are immediately being deleted after download.
---------------------------------------------------------------------
[root@rhel8 pub]# dnf reposync -p /var/ftp/pub/ --delete --download-metadata -n -m --repo=ansible-2-for-rhel-8-x86_64-rpms --repo=ansible-2.8-for-rhel-8-x86_64-rpms
Updating Subscription Management repositories.
Red Hat Ansible Engine 2 for RHEL 8 x86_64 (RPM  11 kB/s | 4.0 kB     00:00    
Red Hat Ansible Engine 2.8 for RHEL 8 x86_64 (R  13 kB/s | 4.0 kB     00:00    
Modular dependency problems:

 Problem 1: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBD-SQLite:1.58:8010020190322125518:073fa5fe-0.x86_64
 Problem 2: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBI:1.641:8010020190322130042:16b3ab4d-0.x86_64
Red Hat Ansible Engine 2 for RHEL 8 x86_64 (RPM 758 kB/s | 1.0 MB     00:01    
comps.xml for repository ansible-2-for-rhel-8-x86_64-rpms saved
(1/3): sshpass-1.06-3.el8ae.x86_64.rpm           81 kB/s |  27 kB     00:00    
(2/3): ansible-test-2.9.0-2.el8.noarch.rpm      1.0 MB/s | 430 kB     00:00    
(3/3): ansible-2.9.0-2.el8.noarch.rpm            13 MB/s |  17 MB     00:01    
Red Hat Ansible Engine 2.8 for RHEL 8 x86_64 (R 104 kB/s | 841 kB     00:08    
comps.xml for repository ansible-2.8-for-rhel-8-x86_64-rpms saved
(1/2): ansible-2.8.6-1.el8ae.noarch.rpm         6.9 MB/s |  15 MB     00:02    
(2/2): sshpass-1.06-3.el8ae.x86_64.rpm          3.3 kB/s |  27 kB     00:08    
[DELETED] /var/ftp/pub/ansible-2-for-rhel-8-x86_64-rpms/Packages/s/sshpass-1.06-3.el8ae.x86_64.rpm
[DELETED] /var/ftp/pub/ansible-2-for-rhel-8-x86_64-rpms/Packages/a/ansible-test-2.9.0-2.el8.noarch.rpm
[DELETED] /var/ftp/pub/ansible-2-for-rhel-8-x86_64-rpms/Packages/a/ansible-2.9.0-2.el8.noarch.rpm
---------------------------------------------------------------------


Scenario 3: When the '--delete' option is not used, the packages don't get deleted. 

--------------------------------------------------------------------------
[root@rhel8 pub]# dnf reposync -p /var/ftp/pub/ --download-metadata -n -m --repo=ansible-2-for-rhel-8-x86_64-rpms --repo=ansible-2.8-for-rhel-8-x86_64-rpms
Updating Subscription Management repositories.
Red Hat Ansible Engine 2 for RHEL 8 x86_64 (RPM 6.8 kB/s | 4.0 kB     00:00    
Red Hat Ansible Engine 2.8 for RHEL 8 x86_64 (R  12 kB/s | 4.0 kB     00:00    
Modular dependency problems:

 Problem 1: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBD-SQLite:1.58:8010020190322125518:073fa5fe-0.x86_64
 Problem 2: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-DBI:1.641:8010020190322130042:16b3ab4d-0.x86_64
Red Hat Ansible Engine 2 for RHEL 8 x86_64 (RPM 714 kB/s | 1.0 MB     00:01    
comps.xml for repository ansible-2-for-rhel-8-x86_64-rpms saved
(1/3): ansible-test-2.9.0-2.el8.noarch.rpm      985 kB/s | 430 kB     00:00    
(2/3): ansible-2.9.0-2.el8.noarch.rpm            18 MB/s |  17 MB     00:00    
(3/3): sshpass-1.06-3.el8ae.x86_64.rpm          7.7 kB/s |  27 kB     00:03    
Red Hat Ansible Engine 2.8 for RHEL 8 x86_64 (R 617 kB/s | 841 kB     00:01    
comps.xml for repository ansible-2.8-for-rhel-8-x86_64-rpms saved
(1/2): sshpass-1.06-3.el8ae.x86_64.rpm           80 kB/s |  27 kB     00:00    
(2/2): ansible-2.8.6-1.el8ae.noarch.rpm          16 MB/s |  15 MB     00:00    
--------------------------------------------------------------------------


Version-Release number of selected component (if applicable):
* Red Hat Enteprise Linux 8.


How reproducible:
* When multiple repos are synched at a time.

Steps to Reproduce:
1. dnf reposync -p /var/ftp/pub/ --delete --download-metadata -n -m --repo=ansible-2-for-rhel-8-x86_64-rpms
2. dnf reposync -p /var/ftp/pub/ --delete --download-metadata -n -m --repo=ansible-2-for-rhel-8-x86_64-rpms --repo=ansible-2.8-for-rhel-8-x86_64-rpms
3. dnf reposync -p /var/ftp/pub/ --download-metadata -n -m --repo=ansible-2-for-rhel-8-x86_64-rpms --repo=ansible-2.8-for-rhel-8-x86_64-rpms

Actual results:
* The packages are getting deleted immeidiately after download.

Expected results:
* The packages should be retained. 

Additional info:
* Here if only 1 repos is synced the issue doesn't occur. It looks like it only checks the last repository and deletes every other repo.

Comment 1 Marek Blaha 2019-11-28 06:51:26 UTC
PR https://github.com/rpm-software-management/dnf-plugins-core/pull/374 fixes the issue.

Comment 8 errata-xmlrpc 2020-04-28 16:49:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.