Bug 1774104 - [RFE] Associate a VM via API or hammer to a compute resource [NEEDINFO]
Summary: [RFE] Associate a VM via API or hammer to a compute resource
Keywords:
Status: CLOSED DUPLICATE of bug 1937470
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.6.0
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-19 15:19 UTC by Kenny Tordeurs
Modified: 2021-10-29 18:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-09 17:02:24 UTC
Target Upstream Version:
bkearney: needinfo? (apatel)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 32769 0 High New Associate a VM via API or hammer to a compute resource 2021-06-10 10:40:40 UTC

Description Kenny Tordeurs 2019-11-19 15:19:39 UTC
Proposed title of this feature request
Associate a VM via API or Hammer to a compute resource

What is the nature and description of the request?
Currently it needs to be done for each VM manually via Webui or for all VMs:
Infrastructure -> compute resources -> *choose compute_resource* -> Virtual Machines -> *find desired vm* -> hover over "Associate VM" button in the top right corner

Why does the customer need this? (List the business requirements
here)
- Does not want to associate all VMs only certain VMs and currently this is not possible outside of the Webui.
- For automation

How would the customer like to achieve this? (List the functional
requirements here)
Hammer or API call for:
~~~
https://satellite-server/compute_resources/compute_resource_id/vms/instance_uuid/associate.
~~~

Comment 8 Dominik Matoulek 2021-06-10 10:40:36 UTC
Created redmine issue https://projects.theforeman.org/issues/32769 from this bug

Comment 9 Mike McCune 2021-07-09 17:02:24 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this feel free to contact your Red Hat Account Team. Thank you.

Comment 10 Yifat Makias 2021-07-22 08:06:30 UTC

*** This bug has been marked as a duplicate of bug 1937470 ***


Note You need to log in before you can comment on or make changes to this bug.