Bug 177412 - boost-1.33.1-4 condition variables broken
Summary: boost-1.33.1-4 condition variables broken
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: boost   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Benjamin Kosnik
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-10 14:20 UTC by Avi Kivity
Modified: 2013-08-09 05:47 UTC (History)
1 user (show)

Fixed In Version: boost-1.33.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 10:24:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Avi Kivity 2006-01-10 14:20:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.0 (like Gecko)

Description of problem:
from glibc changelog:  
  
* Sat Jan 07 2006 Jakub Jelinek <jakub@redhat.com> 2.3.90-29  
- update from CVS  
  - make pthread_mutex_t an unnamed union again, as it affects  
    libstdc++ ABI mangling  
  
looks like boost-1.33.1-4 was built against the bad glibc. any programs 
calling boost::condition::wait() or friends fail to link when compiled with 
the good glibc (either older or current) headers 
 
a rebuild of the boost.src.rpm fixed the problem for me. 

Version-Release number of selected component (if applicable):
boost-1.33.1-4

How reproducible:
Always

Steps to Reproduce:
1. compile & link a program which uses boost::condition 
   

Actual Results:  link error  

Expected Results:  world peace  

Additional info:

please rebuild

Comment 1 Avi Kivity 2006-02-06 15:39:37 UTC
can we rebuild? please? 

Comment 2 Avi Kivity 2006-03-22 10:24:37 UTC
fixed by a mass rebuild. thanks for the attention. 


Note You need to log in before you can comment on or make changes to this bug.