Bug 1774164 - Undefined symbol from OpenColorIO prevents Blender to start
Summary: Undefined symbol from OpenColorIO prevents Blender to start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: OpenColorIO
Version: 31
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-19 17:49 UTC by Arpan Biswas
Modified: 2019-11-29 02:46 UTC (History)
9 users (show)

Fixed In Version: OpenColorIO-1.1.1-4.fc31 OpenColorIO-1.1.1-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-22 00:47:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Arpan Biswas 2019-11-19 17:49:23 UTC
Description of problem:
blender doesn't start and gives a symbol lookup error.

Version-Release number of selected component:
blender-2.80-13.fc31

How reproducible:
Always

Steps to Reproduce:
1. Install blender (sudo dnf install blender)
2. Start blender

Actual results:
blender doesn't start and gives this error message

blender: symbol lookup error: /lib64/libOpenColorIO.so.1: undefined symbol: _ZN4YAML6detail9node_data12empty_scalarB5cxx11E

Expected results:
blender should start

Comment 1 Ben M. 2019-11-19 18:37:17 UTC
I have encountered the same bug on my laptop after installing the current updates. 
I have a Dell PC that I have yet to install the updates and Blender still works. 
I am running Fedora 31 on both. And only the Laptop which currently has all the updates installed is having this issue with blender. 
Could one of the updated packages be the cause of blender breaking?

Comment 2 Luya Tshimbalanga 2019-11-20 01:34:46 UTC
(In reply to Ben M. from comment #1)

> I am running Fedora 31 on both. And only the Laptop which currently has all
> the updates installed is having this issue with blender. 
> Could one of the updated packages be the cause of blender breaking?

It is a bug related to OpenColorIO as the error message shows.
Assigning to the right component.

Comment 3 auppaluri 2019-11-20 06:53:05 UTC
Same issue for me on a fresh install of Fedora 31.
Same terminal output - 
blender: symbol lookup error: /lib64/libOpenColorIO.so.1: undefined symbol: _ZN4YAML6detail9node_data12empty_scalarB5cxx11E

Possibly related to https://bbs.archlinux.org/viewtopic.php?id=248014

I tried installing the alembic library, didn't help

Comment 4 Luya Tshimbalanga 2019-11-20 08:09:45 UTC
After talking with the OpenColorIO at the development mailing list, it turned out the maintainer of yaml-cpp failed to rebuild OpenColorIO with updated yaml-cpp. The fix should come soon.

Comment 5 Fedora Update System 2019-11-20 11:51:32 UTC
FEDORA-2019-0e161784bd has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0e161784bd

Comment 6 Fedora Update System 2019-11-20 11:51:33 UTC
FEDORA-2019-8c4012154d has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8c4012154d

Comment 7 Richard Shaw 2019-11-20 11:54:06 UTC
Please test and if this fixes the problem give positive karma on Bodhi so I can push it to stable sooner than the 7 day waiting period.

Only karma from people with logins count :)

Comment 8 Luya Tshimbalanga 2019-11-20 16:01:59 UTC
Done.

Comment 9 Ben M. 2019-11-20 16:26:12 UTC
Fixed it Thanks.

Comment 10 Ben M. 2019-11-20 16:26:57 UTC
Fixed it Thanks.

Comment 11 Fedora Update System 2019-11-21 02:27:22 UTC
OpenColorIO-1.1.1-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8c4012154d

Comment 12 Fedora Update System 2019-11-21 04:18:08 UTC
OpenColorIO-1.1.1-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0e161784bd

Comment 13 Fedora Update System 2019-11-22 00:47:50 UTC
OpenColorIO-1.1.1-4.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-11-29 02:46:20 UTC
OpenColorIO-1.1.1-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.