Bug 1774173 - Individual project dashboard page generating a repeating console error
Summary: Individual project dashboard page generating a repeating console error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-19 18:21 UTC by Steve Goodwin
Modified: 2020-01-23 11:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:13:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3487 'None' 'open' 'Bug 1774173: Do not use default prop value to avoid update errors' 2019-11-20 08:46:32 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:13:37 UTC

Description Steve Goodwin 2019-11-19 18:21:26 UTC
On an individual project dashboard I am seeing the following error repeat

Error output...

Warning: Maximum update depth exceeded. This can happen when a component calls setState inside useEffect, but useEffect either doesn't have a dependency array, or one of the dependencies changes on every render.
    in Unknown (created by WithDashboardResources)
    in Unknown
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by Firehose)
    in Firehose (created by ConnectFunction)
    in ConnectFunction (created by WithDashboardResources)
    in WithDashboardResources (created by ConnectFunction)
    in ConnectFunction
    in div (created by CardBody)
    in CardBody
    in Unknown
    in article (created by Card)
    in Card
    in Unknown
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by DashboardGrid)
    in div (created by GridItem)
    in GridItem (created by DashboardGrid)
    in div (created by Grid)
    in Grid (created by DashboardGrid)
    in div (created by GridItem)
    in GridItem (created by DashboardGrid)
    in div (created by Grid)
    in Grid (created by DashboardGrid)
    in div (created by DashboardGrid)
    in DashboardGrid (created by ProjectDashboard_)
    in div (created by Dashboard)
    in Dashboard (created by ProjectDashboard_)
    in ProjectDashboard_ (created by ConnectFunction)
    in ConnectFunction (created by Context.Consumer)
    in Route
    in Switch
    in div (created by Data)
    in Data (created by StatusBox)
    in StatusBox
    in div
    in div
    in Unknown
    in Unknown
    in Unknown
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by Firehose)
    in Firehose (created by ConnectFunction)
    in ConnectFunction
    in Unknown (created by DetailsPage)
    in ErrorBoundary (created by DetailsPage)
    in DetailsPage (created by ProjectsDetailsPage)
    in ProjectsDetailsPage (created by AsyncComponent)
    in AsyncComponent
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by Context.Consumer)
    in Route (created by AppContents_)
    in Switch (created by AppContents_)
    in div (created by AppContents_)
    in div (created by AppContents_)
    in section (created by PageSection)
    in PageSection (created by AppContents_)
    in AppContents_ (created by ConnectFunction)
    in ConnectFunction (created by ConnectFunction)
    in ConnectFunction (created by App)
    in main (created by Page)
    in div (created by Page)
    in Page (created by App)
    in App (created by Context.Consumer)
    in Route
    in Router
    in Provider
r @ backend.js:6
warningWithoutStack @ react-dom.development.js:545
warning @ react-dom.development.js:2853
checkForNestedUpdates @ react-dom.development.js:23124
scheduleUpdateOnFiber @ react-dom.development.js:21389
enqueueSetState @ react-dom.development.js:13100
push../node_modules/react/cjs/react.development.js.Component.setState @ react.development.js:325
WithDashboardResources._this.stopWatchK8sResource @ with-dashboard-resources.tsx:148
(anonymous) @ inventory-card.tsx:57
commitHookEffectList @ react-dom.development.js:19980
commitPassiveHookEffects @ react-dom.development.js:20015
callCallback @ react-dom.development.js:347
invokeGuardedCallbackDev @ react-dom.development.js:397
invokeGuardedCallback @ react-dom.development.js:454
flushPassiveEffectsImpl @ react-dom.development.js:22868
unstable_runWithPriority @ scheduler.development.js:643
runWithPriority$2 @ react-dom.development.js:11305
flushPassiveEffects @ react-dom.development.js:22841
(anonymous) @ react-dom.development.js:22419
scheduler_flushTaskAtPriority_Normal @ scheduler.development.js:436
flushTask @ scheduler.development.js:482
flushWork @ scheduler.development.js:599
performWorkUntilDeadline @ scheduler.development.js:231

Comment 2 Yadan Pei 2019-11-21 08:59:32 UTC
The fix is not in any 4.3 nightly payload, will verify when there's newer build

Comment 3 Yadan Pei 2019-11-22 02:27:40 UTC
it's more easily reproducible when visiting project dashboard page via URL directly in automation testing. (in manual testing it's a little hard to reproduce)

Today I run several automation tests and the issue don't happen again.


Verified on 4.3.0-0.nightly-2019-11-21-122827

Comment 5 errata-xmlrpc 2020-01-23 11:13:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.