Bug 1774251 - Some default inkscape extensions doesn't work as they're in python2
Summary: Some default inkscape extensions doesn't work as they're in python2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: inkscape
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-19 21:26 UTC by hugotrip
Modified: 2020-02-01 01:30 UTC (History)
6 users (show)

Fixed In Version: inkscape-1.0-0.beta.fc31.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-01 01:30:49 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gitlab inkscape/inkscape/issues/546 None None None 2019-12-02 15:32:24 UTC

Description hugotrip 2019-11-19 21:26:44 UTC
Description of problem:
some default extensions in the corresponding menu of inkscape are python2 : since usr/bin/python points to python3, they're not working anymore

Version-Release number of selected component (if applicable):
0.92.4.8.fc31

How reproducible:
always

Steps to Reproduce:
1. select a group in inkscape
2. use extension>organize>recursively ungroup (not sure of the exact spelling as I have a french locale)
3. apply
The few extensions I've tried doesn't work, but I've not tried all

Actual results:
a traceback is shown, and the selected group isn't recursively ungrouped

Expected results:
the selected group isn't recursively ungrouped

Additional info:
creating a symlink /usr/local/bin/python pointing at python2 solves the problem.

Comment 1 hugotrip 2019-11-19 21:28:44 UTC
beginning debugging :
/usr/share/inkscape/extensions/ungroup_deep.py has apparently the correct shebangs #! /usr/bin/python2, but it calls /usr/share/inkscape/extensions/simpletransform, which has no shebangs, and causes the error

Comment 2 Gwyn Ciesla 2019-11-20 14:09:23 UTC
This build uses Python 3. See if it helps. https://fedorapeople.org/~limb/inkscape/

Comment 3 hugotrip 2019-11-24 21:43:13 UTC
The extension I use works well with your build, thanks, I will keep it in the meantime.
As I said, I was already able to workaround the bug (launching inkscape via a script which create the symlink pointing to python2, then removing it) : I'm reporting the bug, because other people may encounter it and may not be able to see what the problem is, and how to fix it (I found the cause and the solution after reading a french article about the fedora 31 release, talking about the python3 transition).
So I don't know what's next : will the beta of inkscape 1.0 be released in Fedora 31, or is there someone able to check and fix all scripts within /usr/share/inkscape/extensions/ adding #!/usr/bin/python2 where it's needed ?

Comment 4 Gwyn Ciesla 2019-11-25 16:00:11 UTC
If it's generally stable for you, I'd rather push the beta.

Comment 5 hugotrip 2019-12-01 13:07:04 UTC
Sorry to answer so lately,
and sorry because I messed up my trial at first : the inkscape i tried was not yours, but the flathub one, I also installed before to find a workaround.
So now that I've fixed my mistake, I can tell for the basics I use in inkscape (as a physics teacher, I do mainly diagrams) that the inkscape 1.0 beta is working good, but it doesn't solve my initial problem, as the ungroup_deep.py extension isn't available anymore, as it's no longer in /usr/share/inkscape/extensions/
So, as the extension is removed from inkscape, there isn't anymore errors, but I'm losing a very useful functionality.
Do you know if it is a temporary removal in upstream (maybe because of the need to rewrite it in python3) ?

Comment 6 Gwyn Ciesla 2019-12-02 15:32:08 UTC
I don't know, but I've asked. https://gitlab.com/inkscape/inkscape/issues/546

Comment 7 Gwyn Ciesla 2019-12-02 16:36:07 UTC
From upstream:

Ah, I see. Yes, it's true, they had been forgotten to add. There will soon be a beta2, though, and hopefully, that will be complete. Meanwhile, you can grab the most recent prgram code from https://gitlab.com/inkscape/inkscape/-/archive/master/inkscape-master.zip and drop the most recent extension code from https://gitlab.com/inkscape/extensions/-/archive/master/extensions-master.zip into the /share/extensions directory.

Comment 8 hugotrip 2019-12-02 21:46:43 UTC
Great !
In the meantime I downgraded inkscape to 0.92, but if you need, I can try to copy the extension code in the installation of your rpm, if you think it won't mess the downgrade to 0.92 if it doesn't work.

Comment 9 Fedora Update System 2020-01-31 01:28:51 UTC
inkscape-1.0-0.beta.fc31.4 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d9b0269c6c

Comment 10 Fedora Update System 2020-02-01 01:30:49 UTC
inkscape-1.0-0.beta.fc31.4 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.