Bug 177446 - RFE: modification of beagle requirement of xpdf via xpdf subpackaging.
Summary: RFE: modification of beagle requirement of xpdf via xpdf subpackaging.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: beagle
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-01-10 19:24 UTC by Jef Spaleta
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-01-18 21:52:04 UTC


Attachments (Terms of Use)

Description Jef Spaleta 2006-01-10 19:24:16 UTC
Description of problem:
beagle requires the xpdf package for runtime optional support of pdf metadata
searches using the pdfinfo cli utility that is packaged as part of xpdf package.

The problem is xpdf is also a graphical application which clutters the
applications menus.

The best compromise solution i can think of is to split xpdf into 2 packages
xpdf and xpdf-utils. The xpdf-utils package would carry the cli helper utilities
that beagle uses. This way beagle could require xpdf-utils  and the gui
application wouldn't be pull into the menus and into the mime-type database for
other gnome applications.


I'm filing this against beagle to get input from the beagle package maintainer.
If this seems sensible we could both talk to the xpdf maintainer about making
the required adjustments to the xpdf package to split out the cli utilities into
a xpdf-utils.  I think debian already does this.


-jef

Comment 1 Dave Malcolm 2006-01-10 19:38:28 UTC
Alternatively, does the poppler source tree contain equivalent utilities?
(adding krh to cc)

Comment 2 Jonathan Blandford 2006-01-10 19:42:27 UTC
or, we could build it from poppler.  That has a fork of the xpdf headers in it,
for now.  In the long run, we're hoping to drop them, but it should be fine for FC5.

Comment 3 Jef Spaleta 2006-01-10 20:44:17 UTC
Yes, ideally having the xpdf requirement mutate into a requirement on poppler
would be best. But if that doesn't happen in time for FC5 release, consider a
solution so that beagle doesn't pull in the gui xpdf application into a desktop
install next to evince.

 

Comment 4 Kristian Høgsberg 2006-01-10 21:02:00 UTC
poppler-0.5, which I'll release and build in rawhide in a couple of days, has a
copy of the command line tools from xpdf built against poppler.  Then we just
need to change beagle to require poppler-utils.  I'll post a heads up here when
that happens.


Comment 5 Jef Spaleta 2006-01-10 22:06:12 UTC
hmmm beagle's website lists the pdfinfo as a runtime optional dependancy.
Is it appropriate to single out this one optional runtime dependancy and make it
a hard requirment?  ssindex is also listed an optional runtime requirement and
is provided in the gnumeric package in Extras-development. Shouldn't gnumeric be
pulled in as a requirement if pdfinfo is?  Its not clear from the beagle website
whether wv, which is also in Extras-development, is a runtime or buildtime
dependancy.  I'd love for beagle to be able to index my word and spreadsheet
documents as well as my pdfs, should i file a new RFE to pull wv and gnumeric
back into Core as beagle requirements?

-jef





Comment 6 Kristian Høgsberg 2006-01-11 20:47:41 UTC
OK, poppler-utils-0.5.0-2.0 is now in rawhide and installs these binaries:

  /usr/bin/pdffonts
  /usr/bin/pdfimages
  /usr/bin/pdfinfo
  /usr/bin/pdftohtml
  /usr/bin/pdftops
  /usr/bin/pdftotext

Which all are option compatible with the xpdf equivalents (it's the same code).
 Assuming beagle uses one of these for PDF indexing, it should be safe to switch
the xpdf dependency to a poppler-utils dependency.  Note that the poppler-utils
package conflicts with the xpdf package.

Comment 7 Bastien Nocera 2006-01-13 11:00:06 UTC
See also:
http://bugzilla.gnome.org/show_bug.cgi?id=326814

beagle should really use libpoppler directly, and by itself, rather than relying
on pdfinfo.

Comment 8 Ngo Than 2006-01-18 18:08:49 UTC
There's now a new xpdf-utils subpackage in rawhide, it only includes the command
line tools.

Comment 9 Ray Strode [halfline] 2006-01-18 21:52:04 UTC
But that causes conflicts because poppler-utils provides some of those tools, too.

I changed xpdf to depend on poppler-utils and made xpdf-utils only contain
things that don't conflict.  Hopefully everything should be fixed in tomorrow's
rawhide.


Note You need to log in before you can comment on or make changes to this bug.