Bug 1774465 - m4.xlarge is not supported in sa-east-1
Summary: m4.xlarge is not supported in sa-east-1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Abhinav Dahiya
QA Contact: Yang Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-20 10:58 UTC by Yang Yang
Modified: 2020-05-04 11:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:16:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3051 0 None closed Bug 1774465: aws: pick instance types based on selected availability zones 2021-01-17 08:47:45 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:16:42 UTC

Description Yang Yang 2019-11-20 10:58:35 UTC
Description of problem:
m4.xlarge is not supported in sa-east-1 region of AWS

Version-Release number of the following components:
# ./openshift-install version
./openshift-install v4.3.0
built from commit 55ac3aca9578c038278d7ab24037849e3b9f8296

How reproducible:
100%

Steps to Reproduce:
1. ./openshift-install create cluster --dir test1
? Platform aws
? Region sa-east-1

Actual results:
An error occurs when installing cluster on AWS in sa-east-1b region. Error messages can be found below.                                            
Error launching source instance: Unsupported: Your requested instance type (m4.xlarge) is not supported in your requested Availability Zone (sa-east-1b). Please retry your request by not specifying an Availability Zone or choosing sa-east-1a, sa-east-1c.

Expected results:

Successfully create cluster in region sa-east-1

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Brenton Leanhardt 2019-11-22 14:12:59 UTC
Is this the message we get when a particular AZ is out of capacity for a given node type?  

If we don't allow users to select the AZ with the default UI we should return a more helpful error message than the default AWS error.  Our error message could point users in the right direction for overriding the AZ or machine type.  I'm sure there are other options.

Comment 2 Stephen Cuppett 2019-12-02 12:32:35 UTC
In this case, there is one AZ in this region which has no m4 instance types available (the architecture entirely missing). I do not think we should prioritize this for 4.3.0. Not sure how/if we'd want to fix this. Our hard-coded defaults could run afoul anytime an instance type or family gets retired (or is yet to be launched) in any AZ or new region. IMO, we should already have a default (m5) for the current generation of an instance class and the installer could fall back to a set of known, suitable replacements based on a query for availability.

Comment 4 Yang Yang 2020-02-10 10:37:24 UTC
Verified with 4.4.0-0.nightly-2020-02-09-220310

Creating IPI cluster on AWS within sa-east-1 region succeed. The instances are using m5.large instance type.

The test result is as expected hence moving it to verified state.

Comment 6 errata-xmlrpc 2020-05-04 11:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.