Bug 177452 - Support installs via wireless adapters that require firmware
Support installs via wireless adapters that require firmware
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
: FutureFeature
Depends On:
Blocks: 251941
  Show dependency treegraph
 
Reported: 2006-01-10 15:18 EST by Bill Nottingham
Modified: 2014-03-16 22:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:11:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-01-10 15:18:59 EST
Obviously, this is messy.

There are various steps that would need done.

1) Add a firmware loader that gets the events and handles them to the loader
1a) just use udev w/o using it to load modules?
2) Get the firmware somewhere where you can find it

Since we don't ship the firmware, this is tricky, since it can't be on the basic
boot images.

Options:

a) respin the boot image
b) make a special DD with it
b.2) make it initramfs, cat it onto the boot initrd.img?
c) make an updates.img with it?
d) something else?

Possibly this would need to piggyback on any mkinitrd firmware work.
Comment 1 Jeremy Katz 2006-01-18 11:13:56 EST
Putting on a list for FC6 so we don't forget about it
Comment 2 Jeremy Katz 2006-09-21 23:26:06 EDT
Hasn't happened for FC6, although the infrastructure bits are kind of there. 
The big problem is questions around UI and how to handle loading it.  Which are
largely unresolved due to the fact that the kernel doesn't export bits that tell
us what firmware files go with what modules. 
Comment 4 Red Hat Bugzilla 2007-06-11 23:02:34 EDT
requested by Jams Antill
Comment 8 David Cantrell 2007-08-30 13:21:37 EDT
Closing as rawhide now since we are copying the firmware in to the initrd now.
Comment 9 Orion Poplawski 2008-03-05 17:21:11 EST
Reopening - doing an install on a laptop with Intel 2100 wireless card and the
ipw2100 module is not loaded.
Comment 10 Bug Zapper 2008-05-13 22:04:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Chris Lumens 2008-08-27 13:19:25 EDT
We were explicitly blacklisting wireless modules from appearing in the images for a while for some reason that no one can really remember.  I have added the wireless modules back into the images so we can give them another test.  Remember to use the "allowwireless" command line option.

David - what's the status of wireless now with your NetworkManager loader rewrite?
Comment 12 David Cantrell 2008-10-10 15:00:26 EDT
As of now, there is no capability to configure a wireless interface in the installer.  We have all of the necessary backend components (NM, wpa_supplicant, and wireless firmware), but the frontend components (UI in loader and in anaconda) are not there yet.  Until that point, we won't be able to do wireless installs.
Comment 13 Orion Poplawski 2008-11-13 17:10:46 EST
Just and FYI - on a system that uses a b43 driver (BCM4318) I'm getting prompted for what interface I want to load my kickstart file over.  This probably should get blacklisted since the b43 firmware is not present.
Comment 14 Chris Lumens 2009-02-16 15:11:07 EST
We're being pretty smart about copying over firmware images these days.  Looks like the b43 module needs to be changed so modinfo returns something useful to us.  Right now it's just saying FW13 which isn't really helpful.  Sounds like a new bug to me.

Note You need to log in before you can comment on or make changes to this bug.