Bug 177456 - kudzu segfault at boot
kudzu segfault at boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 15:45 EST by Rusty
Modified: 2014-03-16 22:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.2.41-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 18:45:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kudzu strace from command line (38.00 KB, text/plain)
2006-01-10 15:45 EST, Rusty
no flags Details

  None (edit)
Description Rusty 2006-01-10 15:45:29 EST
Description of problem:
Just installed FC4 from DVD iso downloaded from mirror site.
kudzu segfaults on boot or from command line


Version-Release number of selected component (if applicable):
Not sure how to find. It's whatever is in the current FC4 distribution.
Kernel is 2.6.11-1.1369_FC4.
Also happens with 2.6.11-1.1369_FC4smp.


How reproducible:
Every time

Steps to Reproduce:
1. Install FC4
2. boot or type kudzu at command line
3. 
  
Actual results:
Segmenation Fault

Expected results:
No segfault

Additional info: 
Hardware is Intel D865PERL with P4 3.2ghz, 1gB RAM
/boot is on IDE hda1, grub is on MBR of that disk.
/ and swap are on SATA sda2 (WinXP is on sda1).

During boot, message is:
Checking for new hardware/etc/rc3.d/S05kudzu: line 23: 1749 Segmentation 
fault /usr/sbin/kudzu $KUDZU_ARGS -z 
/etc/rc3.d/S05kudzu: line 23: 1750 Segmentation fault    /usr/sbin/kudzu 
$KUDZU_ARGS
Comment 1 Rusty 2006-01-10 15:45:29 EST
Created attachment 123011 [details]
kudzu strace from command line
Comment 2 Rusty 2006-01-10 16:42:50 EST
kudzu in RPMS on DVD is kudzu-1.1.116.2-2.i386.rpm 
Comment 3 Rusty 2006-01-20 14:06:28 EST
I have now started over and installed FC5, and I have the same problem.
Comment 4 Mathieu de Naurois 2006-01-23 09:31:24 EST
I had the exactly same problem. It turned out that the /etc/sysconfig/hwdata 
file was corrupted (with lots of cryptic characters in the middle).
Erasing this file fixed the problem for ever.
Comment 5 Rusty 2006-01-23 12:14:58 EST
Hmm, I don't seem to have a /etc/sysconfig/hwdata file. 
Comment 6 Mathieu de Naurois 2006-01-23 12:49:17 EST
Sorry, not /etc/sysconfig/hwdata but /etc/sysconfig/hwconf.
I guess it went corrupted after some upgrade of kudzu.
Comment 7 dex 2006-01-25 21:29:56 EST
I've still got problem with latest kudzu from rawhide 

kudzu-devel-1.2.21-1
kudzu-1.2.21-1
during startup:
Checking for new hardware/etc/rc5.d/S05kudzu: line 23: 1717 Segmentation fault
/sbin/kudzu $KUDZU_ARGS
Comment 8 Bill Nottingham 2006-01-26 11:21:33 EST
Dex: your problem is different, and will be fixedin kudzu-1.2.23-1.
Comment 9 Andrew Haley 2006-03-10 05:30:41 EST
I have a segfault with kudzu-1.2.30-1.

I have an IT8212 disk controller.  When there are disks attached to it I get the
kudzu segfault; where there are no disks attached to it, I don't.
Comment 10 Bill Nottingham 2006-03-10 12:53:18 EST
Andrew, can you open up a new bug - this sounds different than what we currently
have in this bug.

Please attach a backtrace from gdb  (you'll probably want to install
kudzu-debuginfo.)
Comment 11 Andrew Haley 2006-03-10 13:45:46 EST
Forget it -- kudzu.x86_64 0:1.2.34.2-1 fixes the problem.

Sorry for the noise.
Comment 12 Leslie Satenstein 2006-03-12 08:43:52 EST
root@localhost log]# rpm -qa "kudzu*"
kudzu-devel-1.2.34.2-1
kudzu-1.2.34.2-1

[root@localhost ~]# uname -r
2.6.15-1.1955_FC5hypervisor
[root@localhost ~]#

I can see the disk led on for about 1 second, then absolute lockup. Tried to
wait 5 minutes to see if there would be a time out, but there was none.
Comment 13 Bill Nottingham 2006-03-13 13:02:04 EST
Leslie - that is unrelated to this issue.
Comment 14 Leslie Satenstein 2006-03-13 16:23:13 EST
Please forgive me. I looked at the title and then skimmed the rest. Only after I
saw that it was a FC4 problem.

I will remove myself from the CC. 
Comment 15 Anti B. 2006-04-14 13:52:49 EDT
Hello!

I have almost the same problem with my FC2 box. Once my PC was shutting down
very slowly I waited the process end. On the next day I turned my PC on again,
and the problem persists.The system stops responding at the hardware/detection
step:FreeConfmodules called with the NULL POINTER. Dont do that.
/etc/rc5.d/S05kudzu line 97 1371 *this number changes every time I try to reboot
PC*  ABORTED /usr/sbin/S05kudzu $KUDZU_ARGS -t 30. After this point in the
kernel without xserver the PC boots normally and goes into text mode. Then I can
access into gui desktop by the following way:login as root, then cd into install
folder, then "nvidia-installer --uninstall. After this reinstall the drivers and
then with "startx" command I can access into GUI. But the PC is without
integrated peripherals such as the network adapter, USB and so on. ONLY PCI
soundcard and PS2 MOUSE and AGP video are working. hwbrowser hangs after its
execution. I am able only browse in the harddisk, launch installed programs and
so on but this all without additional devices. If I log/off then PC goes back to
the textmode and this all will start again. 

 After the some tests of the reboots are clear some facts:
1. If I do the calm reset and try to boot into another kernel without x drivers
then text mode login is successful.
2. If I try to reboot after such login text mode then in the x driver installed
kernel boots with the GUI but will stay slow as before, stops responding at
first  in the swap enabling point or at the second hardware detection point.
3. Reinstall the FC2 is not possible because I have installed two separated FC2
OS-es on the separated hard disks. THe boot files are in the hda but the OS I
try to access is in the hdb. Anaconda gives up at the install information copy 
> No enough space> But I checked the disks all is OK:
I have a DSL linux LIVE CD. This small linux distro found all the peripherals on
my mobo. I mounted my hard disks in the mountpoints and I can to read/write on
them, so HDD-s should be OK. Also with the the FC2 Rescue CD I can to access
into the harddisks..
4. What causes the hang-up of the kudzu? What launches and uses kudzu?
I think that something is wrong with the kudzu bash script but i dont see the
error messages anywhere on the system logfiles...
I tried to turn kudzu off but this not help me...

If somebody can help me then please respond at this thread or mail me at the
address antib@hot.ee
Thanks 
Comment 16 Bill Nottingham 2006-08-24 18:45:38 EDT
Fixed in 1.2.41-1 by removing the offending code.

Note You need to log in before you can comment on or make changes to this bug.