Bug 177459 - xfce4-panel segfaults on startup
xfce4-panel segfaults on startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xfce4-panel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 15:54 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-23 11:23:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-01-10 15:54:03 EST
Description of problem:
Fairly regularly, xfce4-panel will segfaults during a vnc server startup.  It
can be started afterwards without problem.  Not sure if this is really a
xfce4-panel issue or a library issue, but here goes.  Stack trace (may or may
not be valid):

Version-Release number of selected component (if applicable):
#0  0x0000003f2ea3ac58 in IA__g_ascii_strcasecmp (s1=0x4165d6 "xfce",
    s2=0x21 <Address 0x21 out of bounds>) at gstrfuncs.c:1753
#1  0x00000000004116d6 in notify_cb (
    name=0x220000002e <Address 0x220000002e out of bounds>,
channel_name=Variable "channel_name" is not available.
)
    at mcs_client.c:109
#2  0x0000003ae3302bf6 in read_settings (client=0x5e3370, channel_name=Variable
"channel_name" is not available.
)
    at mcs-client.c:250
#3  0x0000003ae3303132 in mcs_client_process_event (client=Variable "client" is
not available.
) at mcs-client.c:792
#4  0x0000000000411747 in client_event_filter (xevent=Variable "xevent" is not
available.
) at mcs_client.c:129
#5  0x0000003a06d3d326 in gdk_event_apply_filters (xevent=0x7fffffd86850,
    event=0x6ecc00, filters=Variable "filters" is not available.
) at gdkevents-x11.c:328
#6  0x0000003a06d3e8bc in gdk_event_translate (display=0x537b30, event=0x6ecc00,
    xevent=0x7fffffd86850, return_exposes=0) at gdkevents-x11.c:872
#7  0x0000003a06d40078 in _gdk_events_queue (display=0x537b30) at
gdkevents-x11.c:2193
#8  0x0000003a06d400df in gdk_event_dispatch (source=Variable "source" is not
available.
) at gdkevents-x11.c:2253
#9  0x0000003f2ea24a9e in IA__g_main_context_dispatch (context=0x546c80) at
gmain.c:1934
#10 0x0000003f2ea27734 in g_main_context_iterate (context=0x546c80, block=1,
    dispatch=1, self=Variable "self" is not available.
) at gmain.c:2565
#11 0x0000003f2ea27c20 in IA__g_main_loop_run (loop=0x6f89f0) at gmain.c:2769
#12 0x0000003a06802145 in IA__gtk_main () at gtkmain.c:1009
#13 0x00000000004113d2 in main (argc=1, argv=0x7fffffd86cd8) at main.c:501
(gdb) up
#1  0x00000000004116d6 in notify_cb (
    name=0x220000002e <Address 0x220000002e out of bounds>,
channel_name=Variable "channel_name" is not available.
)
    at mcs_client.c:109
109         if (g_ascii_strcasecmp (CHANNEL, channel_name))
(gdb) list
104     /* event handling */
105     static void
106     notify_cb (const char *name, const char *channel_name,
107                McsAction action, McsSetting * setting, void *data)
108     {
109         if (g_ascii_strcasecmp (CHANNEL, channel_name))
110             return;
111
112         switch (action)
113         {


How reproducible:
Fairly.

Steps to Reproduce:
1. startup vncserver with the following xstartup:

#!/bin/sh

ulimit -c unlimited

if [ -f $HOME/.Xresources ]
then
   xrdb $HOME/.Xresources
fi
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#mwm
xfwm4 &
xfce4-panel &
Comment 1 Kevin Fenzi 2006-01-10 17:59:55 EST
Greetings. I don't have a x86_64 test box, so it might be difficult to duplicate
this here. ;( 

Can you try a few things: 

- rpm -ivh
http://download.fedora.redhat.com/pub/fedora/linux/extras/4/x86_64/debug/xfce4-panel-debuginfo-4.2.3-1.fc4.x86_64.rpm
(assuming you are running the latest version from extras). Then re-run your gdb
traces? This should hopefully provide more information. 

- Running xfce4-panel & in your xstartup is not the prefred way to start xfce,
(although it should work). can you try: 
exec startxfce4
and see if it makes any diffrence? 
Comment 2 Orion Poplawski 2006-01-10 18:06:19 EST
The debuginfo package is installed (otherwise you wouldn't see line number info).

We'll try startxfce4 and see if that helps.
Comment 3 Kevin Fenzi 2006-01-11 00:50:18 EST
Just got access to a fc4 x86_64 box to test with. 

I used your ~/.vnc/xstartup file from above.
The first time I ran vncserver everything was fine, but after that I was able to
see xfce4-panel die like you were. ;) 

It looks like it's a race condition if you try and start xfwm4 and xfce4-panel
at the same time. If I put a 'sleep 2' between them I can't get it to fail. 
It also always works for me if I use the 'exec startxfce4' (which needs
xfce-utils installed, BTW). 

I did some tracing on xfce4-panel, and it dies when it's trying to talk to
xfce-mcs-manager it looks like. 

I will mention this issue on the upstream lists, although they may well say
"don't do that then". 

If you could confirm if startxfce4 works that would be good. 
Comment 4 Kevin Fenzi 2006-01-21 19:13:34 EST
Any news on if using startxfce4 works around the issue for you?

I posted to the upstream list, but didn't get any response. 
I can file an upstream bug on it...

Comment 5 Orion Poplawski 2006-01-23 11:23:09 EST
So far no problems with startxfce4.  I think that will work for us.

Note You need to log in before you can comment on or make changes to this bug.