Bug 1774616 - buildlogoptions has drifted from podlogoptions
Summary: buildlogoptions has drifted from podlogoptions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Corey Daley
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-20 14:51 UTC by Ben Parees
Modified: 2020-10-27 15:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:54:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift api pull 652 0 None closed Bug 1774616: BuildLogOptions has drifted from PodLogOptions 2020-06-16 01:37:11 UTC
Github openshift oc pull 433 0 None closed Bug 1774616: Update BuildLogOptions 2020-06-16 01:37:11 UTC
Github openshift openshift-apiserver pull 110 0 None closed Bug 1774616: Remove insecureSkipTLSVerifyBackend bypass for BuildLogOptions 2020-06-16 01:37:11 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:55:08 UTC

Description Ben Parees 2019-11-20 14:51:50 UTC
Description of problem:
see: 
https://github.com/openshift/openshift-apiserver/pull/44/commits/0da186c8c9d3767cf6579b350dd1e522f933ca2b

buildlogoptions should support the same fields as podlogoptions.



Version-Release number of selected component (if applicable):
4.3  (kube 1.17)


How reproducible:
always

Comment 1 Adam Kaplan 2019-11-21 13:30:58 UTC
Targeting 4.4.0

Comment 4 wewang 2020-06-16 06:16:15 UTC
Verified in:
Client Version: 4.6.0-202006092217-f30826e
Server Version: 4.4.8
Kubernetes Version: v1.17.1+3f6f40d

Steps:
[wewang@wangwen work]$ oc logs -f build/ruby-hello-world-1  --insecure-skip-tls-verify-backend=true --loglevel=7
I0616 11:11:57.408624   10088 loader.go:375] Config loaded from file:  /home/wewang/.kube/config
I0616 11:11:57.417970   10088 round_trippers.go:420] GET https://api.qe-groupd-0616.qe.devcluster.openshift.com:6443/apis/build.openshift.io/v1/namespaces/wewang/builds/ruby-hello-world-1
I0616 11:11:57.417995   10088 round_trippers.go:427] Request Headers:
I0616 11:11:57.418000   10088 round_trippers.go:431]     Authorization: Bearer <masked>
I0616 11:11:57.418008   10088 round_trippers.go:431]     Accept: application/json, */*
I0616 11:11:57.418016   10088 round_trippers.go:431]     User-Agent: oc/4.6.0 (linux/amd64) kubernetes/f30826e
I0616 11:11:57.977116   10088 round_trippers.go:446] Response Status: 200 OK in 559 milliseconds
I0616 11:11:57.984846   10088 round_trippers.go:420] GET https://api.qe-groupd-0616.qe.devcluster.openshift.com:6443/apis/build.openshift.io/v1/namespaces/wewang/builds/ruby-hello-world-1/log?follow=true&insecureSkipTLSVerifyBackend=true



when tested 4.5, logs are not include insecureSkipTLSVerifyBackend
#  ./oc version
Client Version: 4.5.0-202005231517-44354e2
# ./oc logs -f build/ruby-ex-1 --insecure-skip-tls-verify-backend=true --loglevel=7
I0616 14:04:33.024339   13621 loader.go:375] Config loaded from file:  /root/.kube/config
I0616 14:04:33.033856   13621 round_trippers.go:420] GET https://api.huir-upg.qe.devcluster.openshift.com:6443/apis/build.openshift.io/v1/namespaces/devexpupgrade/builds/ruby-ex-1
I0616 14:04:33.033882   13621 round_trippers.go:427] Request Headers:
I0616 14:04:33.033886   13621 round_trippers.go:431]     Accept: application/json, */*
I0616 14:04:33.033893   13621 round_trippers.go:431]     User-Agent: oc/4.5.0 (linux/amd64) kubernetes/44354e2
I0616 14:04:33.033923   13621 round_trippers.go:431]     Authorization: Bearer <masked>
I0616 14:04:34.585280   13621 round_trippers.go:446] Response Status: 200 OK in 1551 milliseconds
I0616 14:04:34.595114   13621 round_trippers.go:420] GET https://api.huir-upg.qe.devcluster.openshift.com:6443/apis/build.openshift.io/v1/namespaces/devexpupgrade/builds/ruby-ex-1/log?follow=true

Comment 6 errata-xmlrpc 2020-10-27 15:54:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.