Bug 177462 - Kernel crashes on NFS mount with ACL's
Kernel crashes on NFS mount with ACL's
Status: CLOSED DUPLICATE of bug 177522
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 16:08 EST by Tom Sightler
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 10:44:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Sightler 2006-01-10 16:08:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7

Description of problem:
We have a RHEL3 U6 system sharing a 300GB ext3 filesystem with ACL support via NFS and Samba.  We have about 10 RHEL3 systems, and 2 RHEL4 systems which access this share via NFS.  The RHEL3 systems use full ACL support and work fine.

Previous releases (U2 and earlier) of RHEL4 did not appear to support ACL over NFS and they work fine, however, we recently upgraded two test systems to RHEL4 U3 beta.  This code includes support for ACL's over NFS.  When mounting this share from the RHEL4 system and simply navigating to a directory and running 'ls -ltr' the system will hang completely.  Totally non-responsive.

Mounting the same share using the 'noacl' option will allow the 'ls -ltr' command to work properly so we're quite confident the issue is with the ACL support. 

Version-Release number of selected component (if applicable):
kernel-2.6.9-27.ELsmp

How reproducible:
Always

Steps to Reproduce:
1. Use RHEL3 system to share out ACL enabled volume via NFS
2. Use RHEL4 system to mount this share
3. Run 'ls -ltr' on any volume that has ACL's
  

Actual Results:  System hangs.  If run from the console you get a stack trace.

Expected Results:  Should simply list the files.

Additional info:

I only got a partial stack trace, copied by hand so possibly some errors:

[<f8b521ec>] xdr_partial_copy_from_skb+0xab/0x128 [sunrpc]
[<f8b4a3e3>] tcp_data_recv+0x2c4/0c3b8 [sunrpc]
[<f8b4a4d7>] tcp_copy_data+0x0/0x33
[<c01b471f>] security_port_sid [sunrpc]
[<c029dbbd>] tcp_read_sock
[<f8b4a11f>] tcp_data_recv
[<f8b4a569>] tcp_data_ready
[<c02a50ac>] tcp_rcv_established
[<c02acc42>] tcp_v4_do_rcv
[<c02ad1d1>] tcp_v4_rcv
[<c02b3883>] udp_rcv
[<c02953e4>] ip_local_delivery
[<c02a59ac>] ip_rcv
[<c027f329>] netif_receive_skb
[<c027f3d2>] process_backlog
[<c027f4b5>] net_rx_action
.
.
.
Comment 1 Jeff Needle 2006-01-11 10:44:18 EST
Tom, looks like our quality group found this around the same time you reported
it and that bug has a complete trace, so I'm going to close this as a duplicate
and add you as a CC to that one.

Thanks for letting us know about this!

*** This bug has been marked as a duplicate of 177522 ***

Note You need to log in before you can comment on or make changes to this bug.