Bug 1774642 - `oc adm release extract --tools` fails on macOS
Summary: `oc adm release extract --tools` fails on macOS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Yaakov Selkowitz
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-20 15:26 UTC by Samuel Padgett
Modified: 2021-01-04 23:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:13:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 171 0 'None' closed Bug 1774642: Avoid hard links in cli-artifacts 2021-01-05 00:21:43 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:13:36 UTC

Description Samuel Padgett 2019-11-20 15:26:12 UTC
This command fails on macOS:

$ oc adm release extract --tools registry.svc.ci.openshift.org/ocp/release:4.3.0-0.ci-2019-11-20-121416
error: image did not contain usr/share/openshift/mac/oc

Previous releases like registry.svc.ci.openshift.org/ocp/release:4.3.0-0.ci-2019-11-17-192542 seem OK.

$ oc version
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0+b4261e0", GitCommit:"b4261e07ed", GitTreeState:"clean", BuildDate:"2019-07-06T03:16:01Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"darwin/amd64"}
Server Version: version.Info{Major:"1", Minor:"16+", GitVersion:"v1.16.2", GitCommit:"c6489fd", GitTreeState:"clean", BuildDate:"2019-11-20T00:55:37Z", GoVersion:"go1.12.9", Compiler:"gc", Platform:"linux/amd64"}

Comment 2 W. Trevor King 2019-11-21 17:36:57 UTC
oc#171 is sufficient for this, oc#172 was an alternative and shouldn't block this bug getting verified.

Comment 4 zhou ying 2019-11-26 08:49:06 UTC
Can't reproduce the issue with latest oc client and payload:

Comment 5 zhou ying 2019-11-26 08:51:34 UTC
Zhous-MacBook-Pro:1125 zhouying$ oc version
Client Version: openshift-clients-4.3.0-201910250623-68-g9d412f42

Zhous-MacBook-Pro:1125 zhouying$ oc adm release extract --tools registry.svc.ci.openshift.org/ocp/release:4.3.0-0.ci-2019-11-22-122829
Zhous-MacBook-Pro:1125 zhouying$ ll
total 251152
-rwxr-xr-x  1 zhouying  wheel    26M Nov 22 00:45 openshift-client-mac-4.3.0-0.ci-2019-11-22-122829.tar.gz
-rwxr-xr-x  1 zhouying  wheel    83M Nov 22 05:54 openshift-install-mac-4.3.0-0.ci-2019-11-22-122829.tar.gz
-rw-r--r--  1 zhouying  wheel    18K Nov 26 16:49 release.txt
-rw-r--r--  1 zhouying  wheel   325B Nov 26 16:49 sha256sum.txt

Comment 7 errata-xmlrpc 2020-01-23 11:13:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.