Bug 1774702 - Navigating from the Dashboard results in two navigation items highlighted
Summary: Navigating from the Dashboard results in two navigation items highlighted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Mac OS
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1776486
TreeView+ depends on / blocked
 
Reported: 2019-11-20 18:26 UTC by cbritt
Modified: 2020-05-04 11:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When a user navigates using a link outside the nav, the last selected nav item maintains focus and therefore maintains its highlight. Consequence: Two items in the nav are highlighted, but only one should be. Fix: Added CSS rules to eliminate the highlighted styles for focused nav items. Result: Only the active nav item is highlighted.
Clone Of:
: 1776486 (view as bug list)
Environment:
Version: 4.3.0-0.ci-2019-11-20-134433 Cluster ID: c1ba6d4b-e6cd-460b-903a-afef98aec924 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.97 Safari/537.36
Last Closed: 2020-05-04 11:16:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of navigation showing two items highlighted (154.03 KB, image/png)
2019-11-20 18:26 UTC, cbritt
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3542 'None' closed Bug 1774702: Fix bug where multiple nav items are highlighted 2020-06-30 20:12:48 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:16:42 UTC

Description cbritt 2019-11-20 18:26:58 UTC
Created attachment 1638182 [details]
Screenshot of navigation showing two items highlighted

Description of problem:
Following a link from the Dashboard results in two navigation items being highlighted: Dashboard and the destination nav item

Version-Release number of selected component (if applicable):
4.3.0-0.ci-2019-11-20-134433

How reproducible:
Very

Steps to Reproduce:
1. Follow a link on the dashboard, to pods, for example
2.
3.

Actual results:
Both the Dashboard and destination navigation items are highlighted

Expected results:
Only the destination navigation items is highlighted

Additional info:

Comment 1 Robb Hamilton 2019-11-21 14:07:15 UTC
I an unable to reliably reproduce this bug in Chrome 78, Firefox 70.0.1, or Safari 13.0.3 on MacOS 10.15.1.  Any pointers, Cameron?

Comment 2 Robb Hamilton 2019-11-21 14:24:35 UTC
This seems to be specific to Chrome, and does not reproduce consistently.  Therefore, I am reducing the severity.

Comment 3 Robb Hamilton 2019-11-22 16:06:28 UTC
Note `Dashboards` needs to be the last item clicked prior to clicking `Pods` in order to reproduce the bug.

Comment 5 Yanping Zhang 2019-11-26 09:38:50 UTC
payload: 4.4.0-0.nightly-2019-11-26-041012
Checked on ocp 4.4 cluster with above payload version. Browsers cover chrome78 and firefox70. Nav from "Dashboard" to pods/deployments page, only the destination item is highlighted. No other navigation issue is found, so move the bug to Verified.

Comment 7 errata-xmlrpc 2020-05-04 11:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.