Bug 1774705 - [abrt] freecad: namemap_find_or_add_string(): FreeCAD killed by SIGABRT
Summary: [abrt] freecad: namemap_find_or_add_string(): FreeCAD killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:6045259ca51b0f72a109ff53dfe...
Depends On:
Blocks: 1784153
TreeView+ depends on / blocked
 
Reported: 2019-11-20 18:40 UTC by Petri Salminen
Modified: 2020-01-05 00:40 UTC (History)
4 users (show)

Fixed In Version: freecad-0.18.4-3.fc30 freecad-0.18.4-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-04 22:14:59 UTC


Attachments (Terms of Use)
File: backtrace (118.04 KB, text/plain)
2019-11-20 18:40 UTC, Petri Salminen
no flags Details
File: cgroup (341 bytes, text/plain)
2019-11-20 18:40 UTC, Petri Salminen
no flags Details
File: core_backtrace (35.97 KB, text/plain)
2019-11-20 18:40 UTC, Petri Salminen
no flags Details
File: cpuinfo (1.46 KB, text/plain)
2019-11-20 18:41 UTC, Petri Salminen
no flags Details
File: dso_list (24.21 KB, text/plain)
2019-11-20 18:41 UTC, Petri Salminen
no flags Details
File: environ (1.36 KB, text/plain)
2019-11-20 18:41 UTC, Petri Salminen
no flags Details
File: limits (1.29 KB, text/plain)
2019-11-20 18:41 UTC, Petri Salminen
no flags Details
File: maps (156.21 KB, text/plain)
2019-11-20 18:41 UTC, Petri Salminen
no flags Details
File: mountinfo (3.93 KB, text/plain)
2019-11-20 18:41 UTC, Petri Salminen
no flags Details
File: open_fds (2.29 KB, text/plain)
2019-11-20 18:41 UTC, Petri Salminen
no flags Details
File: proc_pid_status (1.32 KB, text/plain)
2019-11-20 18:41 UTC, Petri Salminen
no flags Details

Description Petri Salminen 2019-11-20 18:40:52 UTC
Description of problem:
I ran FreeCAD, opened a new document and changed to Arch Workbench, then it got a segmentation fault.

Version-Release number of selected component:
1:freecad-0.18.4-1.fc30

Additional info:
reporter:       libreport-2.11.3
backtrace_rating: 3
cmdline:        FreeCAD
crash_function: namemap_find_or_add_string
executable:     /usr/lib64/freecad/bin/FreeCAD
journald_cursor: s=25fc941546d140acb2d3e92dbf078ad7;i=55412;b=7af5ae0242e54986bbdd07990ab2481c;m=5c8a2d2a0d;t=597cb0d0a5a09;x=162ce4974c3c040b
kernel:         5.3.11-200.fc30.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
xsession_errors:

Comment 1 Petri Salminen 2019-11-20 18:40:56 UTC
Created attachment 1638185 [details]
File: backtrace

Comment 2 Petri Salminen 2019-11-20 18:40:57 UTC
Created attachment 1638186 [details]
File: cgroup

Comment 3 Petri Salminen 2019-11-20 18:40:58 UTC
Created attachment 1638187 [details]
File: core_backtrace

Comment 4 Petri Salminen 2019-11-20 18:41:00 UTC
Created attachment 1638188 [details]
File: cpuinfo

Comment 5 Petri Salminen 2019-11-20 18:41:02 UTC
Created attachment 1638189 [details]
File: dso_list

Comment 6 Petri Salminen 2019-11-20 18:41:03 UTC
Created attachment 1638190 [details]
File: environ

Comment 7 Petri Salminen 2019-11-20 18:41:04 UTC
Created attachment 1638191 [details]
File: limits

Comment 8 Petri Salminen 2019-11-20 18:41:06 UTC
Created attachment 1638192 [details]
File: maps

Comment 9 Petri Salminen 2019-11-20 18:41:08 UTC
Created attachment 1638193 [details]
File: mountinfo

Comment 10 Petri Salminen 2019-11-20 18:41:09 UTC
Created attachment 1638194 [details]
File: open_fds

Comment 11 Petri Salminen 2019-11-20 18:41:10 UTC
Created attachment 1638195 [details]
File: proc_pid_status

Comment 12 Richard Shaw 2019-11-20 19:27:57 UTC
Can you test the package in updates-testing and see if the problem is reproducible?

https://bodhi.fedoraproject.org/updates/FEDORA-2019-0e161784bd

Comment 13 Richard Shaw 2019-11-20 19:30:51 UTC
Wrong update link, use this one instead:

https://bodhi.fedoraproject.org/updates/FEDORA-2019-737d8cd579

Comment 14 Richard Shaw 2019-11-20 19:35:00 UTC
Also, if you're running Wayland, it's known to cause issues so try Xorg instead to see if there's any difference.

Comment 15 Priit Laes 2019-12-01 20:34:19 UTC
Firstly, a simpler workaround to force it run as Xorg application under Wayland:

$ QT_QPA_PLATFORM=xcb /usr/bin/FreeCAD

And there's a hint about this issue being a Coin3 library issue:

https://forum.freecadweb.org/viewtopic.php?t=33359

Comment 16 Richard Shaw 2019-12-02 15:31:21 UTC
I'm not opposed to trying the solution in the forum thread, however, there are two problems:

1. Coin4 is only available (outside of my COPR) in Rawhide (f32).
2. I am not the maintainer of Coin3 and he's already pissed about moving the Coin3D stack to Coin4 in Rawhide.
3. Coin3 is autotools based, not CMake based, so I would have to adapt the work around.

Comment 17 Richard Shaw 2019-12-02 17:06:59 UTC
I just rebuilt Coin4 without GLX in my COPR if you would like to test...

https://copr.fedorainfracloud.org/coprs/hobbes1069/FreeCAD_NEXT/

Comment 18 Priit Laes 2019-12-02 19:43:21 UTC
(In reply to Richard Shaw from comment #17)
> I just rebuilt Coin4 without GLX in my COPR if you would like to test...
> 
> https://copr.fedorainfracloud.org/coprs/hobbes1069/FreeCAD_NEXT/

Is it possible to rebuild freecad against Coin4?

Comment 19 Richard Shaw 2019-12-02 21:45:52 UTC
Possible? Yes... Practical? No...

The first obstacle is that major upgrades within a Fedora release is discouraged. Secondly, it doesn't help that the whole Coin3D stack needs to be moved with it (SoQt, SIMVoleon, etc) and I'm not the primary maintainer of those packages. Thirdly the primary maintainer of those packages is hostile to making those changes. He didn't want to make the changes in Rawhide but he didn't have a choice.

Comment 20 Fedora Update System 2019-12-18 01:25:33 UTC
Coin4-4.0.0-4.fc31, freecad-0.18.4-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e935331fe6

Comment 21 Fedora Update System 2019-12-18 02:08:47 UTC
Coin4-4.0.0-4.fc30, freecad-0.18.4-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3d88bddf00

Comment 22 Fedora Update System 2019-12-18 09:58:30 UTC
FEDORA-2019-3d88bddf00 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3d88bddf00

Comment 23 Fedora Update System 2019-12-18 09:58:32 UTC
FEDORA-2019-e935331fe6 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e935331fe6

Comment 24 Fedora Update System 2020-01-04 22:14:59 UTC
Coin4-4.0.0-4.fc30, freecad-0.18.4-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2020-01-05 00:40:16 UTC
Coin4-4.0.0-4.fc31, freecad-0.18.4-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.