Bug 1774720 - potential memory leak not handling returned context cancellation functions when reconciling
Summary: potential memory leak not handling returned context cancellation functions wh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.0
Assignee: Daniel Sover
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-20 19:13 UTC by Daniel Sover
Modified: 2020-01-23 11:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:13:20 UTC
Target Upstream Version:
dsover: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1116 'None' closed Bug 1774720: catalogsource context cancel function leak 2020-06-29 06:40:15 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:13:36 UTC

Comment 4 Jian Zhang 2019-11-22 09:46:48 UTC
Hi Daniel

Thanks for your explanation!
We running an OCP 4.3 for about 14 hours and have a regression test round on it. 
No memory leak found, LGTM, verify it.
Cluster version is 4.3.0-0.nightly-2019-11-21-122827
mac:~ jianzhang$ oc exec catalog-operator-6b49d676c7-5fv6j -- olm --version
OLM version: 0.13.0
git commit: ba10413e72cfe23724edc588ff25f36dfdbeb37e

mac:~ jianzhang$ oc adm top pods
NAME                                CPU(cores)   MEMORY(bytes)   
catalog-operator-6b49d676c7-5fv6j   6m           48Mi            
olm-operator-c495ddf7c-jtx57        19m          83Mi            
packageserver-754d4947cb-mwd95      1m           19Mi            
packageserver-754d4947cb-n42gl      1m           20Mi

Comment 6 errata-xmlrpc 2020-01-23 11:13:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.