Bug 177477 - Kernel panic - not syncing: PCI-DMA:high address but no IOMMU
Kernel panic - not syncing: PCI-DMA:high address but no IOMMU
Status: CLOSED DUPLICATE of bug 169115
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-01-10 18:11 EST by Orla Hegarty
Modified: 2013-08-05 21:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-15 12:36:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Orla Hegarty 2006-01-10 18:11:11 EST
Description of problem:

Version-Release number of selected component (if applicable):
This occured while installing a fresh machine from RHEL 4 U2 CD set. ( x86_64 ) 

This fresh new machine is a HP Prolient DL145 Generation 2 Server 1 U rack mount
with 4GB of ram and two AMD CPUs

This occurs when attempting to install from CD ( the CDs are fine; they
installed a different machine successfully ) 

Graphical or text mode it fails in the same place. 

Is x86_64 RHEL 4 U2 the same for AMD and Intel ? 

How reproducible:
Consistently and has been observed on two of these machines.

Steps to Reproduce:
1. Insert RHEL 4 U2 CD disc 1 and boot
2. Choose either graphical or text install. 
3. Installation fails quickly with the message
Kernel panic - not syncing: PCI-DMA:high address but no IOMMU
Actual results:

Expected results:

Additional info:
Comment 1 Orla Hegarty 2006-01-10 18:33:33 EST
Here is further information concerning the kernel panic message ..

ACPI: ( Supports S0 S1 S2 S3 S4 S5 )
ACPI Wakeup devices:
md: Autodetecting RAID array.
md: autorun ...
md:  ... autorun DONE.
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem)
anaconda installer init version starting
mounting /proc filesystem ... DONE
mounting /dev/pts (unix98 pty) filesystem ... DONE
mounting /sys filesystem ... DONE
trying to remount root filesystem read write ... done
mounting /tmp as ramfs ... DONE
running install ...
running /sbin/loader
Kernel panic - not syncing: PCI-DMA:high address but no IOMMU

Comment 2 Orla Hegarty 2006-01-10 21:01:56 EST
OK there must be an existing bug open for this one. Not sure which one though
from my quick glance around.

1. Go into the bios -> Advanced -> MCFG Table 
2. Set the option to DISABLED

Note the description for this option is as follows:
"This feature needs to be disabled for some linux version to work with devices
on PCI-X Slots correctly. Example. RHAS 4.0 Update 1 (32 bits or 64 bits)"

So this is a known problem for Red Hat Enterprise Linux 4.0 U1 and is still a
problem in U2. 

Comment 3 Linda Wang 2006-01-18 00:03:10 EST
> there must be an existing bug open for this one.
Can you check BZ#169115 to see if it is similiar issue that
you are running into?
Comment 4 Orla Hegarty 2006-02-15 12:36:25 EST
Sorry I missed your comment / update. 

I took a look at the other bug and it sure looks like the same problem. I am
going to go ahead and mark my bug as a duplicate of that one. Thanks for
pointing it out !!!

*** This bug has been marked as a duplicate of 169115 ***

Note You need to log in before you can comment on or make changes to this bug.