Bug 1774786 - UX: Tell user if cached creds (e.g. ~/.azure) are used to avoid confusion
Summary: UX: Tell user if cached creds (e.g. ~/.azure) are used to avoid confusion
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Fabiano Franz
QA Contact: Etienne Simard
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-20 23:23 UTC by Nick Stielau
Modified: 2020-05-04 11:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:16:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:16:42 UTC

Description Nick Stielau 2019-11-20 23:23:31 UTC
Description of problem:
Customers have been confused by the silent use of cached information from the installer, specifically ~/.azure.  We should let them know in the CLI output if we are using cached inputs.


How reproducible:

Steps to Reproduce:
1.  Running installer for Azure cluster
2. Put in all fields
3. Run again
4. Notice that fewer fields are requested

Actual results:
Silent use of cached creds

Expected results:
Installer notes that it is using cached creds, with a location on disk or link for docs

Comment 2 Abhinav Dahiya 2020-01-30 22:04:47 UTC
https://github.com/openshift/installer/pull/2664

This should have been fixed by PR ^^

Comment 5 errata-xmlrpc 2020-05-04 11:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.