Bug 1774843 - "Rebuild" item is disabled for common user
Summary: "Rebuild" item is disabled for common user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1774842 1779316
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-21 05:46 UTC by Yanping Zhang
Modified: 2020-02-24 16:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1774842
Environment:
Last Closed: 2020-02-24 16:52:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3683 0 None closed [release-4.2] Bug 1774843: Fix clone build access review 2020-02-10 14:35:14 UTC
Red Hat Product Errata RHBA-2020:0460 0 None None None 2020-02-24 16:52:59 UTC

Description Yanping Zhang 2019-11-21 05:46:33 UTC
4.2.0-0.nightly-2019-11-19-194213
Issue also exists on OCP 4.2.
+++ This bug was initially created as a clone of Bug #1774842 +++

Description of problem:
Common user tries to rebuild a build by click "Rebuild" item in action list from console. The "Rebuild" item is gray and disabled.

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-19-122017

How reproducible:
Always

Steps to Reproduce:
1.Common user creates app in project, after starts a build, tries to rebuild the build by click "Rebuild" item in action list.
2.
3.

Actual results:
1.The "Rebuild" item is gray and disabled.


Expected results:
1."Rebuild" should be enabled and user could rebuild successfully.

Additional info:
Cluster-admin user could rebuild successfully.

Comment 1 Samuel Padgett 2019-11-21 14:50:50 UTC
Lowering the severity because this only happens immediately after creating the build and there's a simple workaround. (See discussion in bug 1774842.)

Comment 3 Yanping Zhang 2020-02-10 14:48:20 UTC
Checked on ocp 4.2.18, now common user could click "Rebuild" button and trigger new build successfully.
The bug is fixed.

Comment 5 errata-xmlrpc 2020-02-24 16:52:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0460


Note You need to log in before you can comment on or make changes to this bug.