Bug 177487 - evolution doesn't compile against libnotify
evolution doesn't compile against libnotify
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On: 177666 177667 177670
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-01-10 20:30 EST by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 14:28:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 325629 None None None Never

  None (edit)
Description Dave Malcolm 2006-01-10 20:30:09 EST
Description of problem:
If you have libnotify [1] installed when trying to rebuild evolution, the build
fails owing to some new stuff added to notify.h which upstream are making use of:
Error is in calendar/gui/alarm-notify:
alarm-queue.c: In function 'popup_notification':

alarm-queue.c:1463: error: 'NotifyIcon' undeclared (first use in this function)

alarm-queue.c:1463: error: (Each undeclared identifier is reported only once

alarm-queue.c:1463: error: for each function it appears in.)

alarm-queue.c:1463: error: 'icon' undeclared (first use in this function)

alarm-queue.c:1474: error: implicit declaration of function
'notify_icon_new_from_uri'

alarm-queue.c:1514: error: implicit declaration of function
'notify_send_notification'


HEAD appears to contain the necessary API stuff: 
http://svn.galago-project.org/trunk/libnotify/libnotify/notify.h

but 0.3.0 doesn't:
http://svn.galago-project.org/releases/libnotify/0.3.0/libnotify/notify.h

So it looks like upstream are working with svn snapshots of libnotify; I'll try
 to patch around this within evolution, or else we could use a more
bleeding-edge libnotify 

[1] as opposed to libnotify-devel; I filed bug 177484 about this

Version-Release number of selected component (if applicable):
evolution-2.5.4-2
libnotify-0.3.0-2

How reproducible:
100%

Should also add the necessary Requires/BuildRequires to evolution so that we're
deterministic about which notification implementation gets built
Comment 1 Ray Strode [halfline] 2006-01-11 10:36:04 EST
Okay, so we can either disable libnotify support or port to the new api.

We gotta do one or the other before fc5 if evolution isn't building.
Comment 2 John (J5) Palmieri 2006-01-11 11:24:16 EST
Port it.  Dave if you send me the file(s) I'll do the initial diff then we can
test together.
Comment 3 Dave Malcolm 2006-01-11 17:12:28 EST
Have committed a patch to package CVS; building as evolution-2.5.4-4; ought to
at least compile, though the calendar's crashing quite a lot for me ATM which
makes it difficult to test this part of the code, alas.
Comment 5 Dave Malcolm 2006-01-12 15:02:36 EST
I've reported this upstream here: http://bugzilla.gnome.org/show_bug.cgi?id=326757
Comment 6 Dave Malcolm 2006-01-12 15:34:54 EST
Upstream report was marked as a dup of
http://bugzilla.gnome.org/show_bug.cgi?id=325629
which has a slightly different patch from Ubuntu attached
Comment 7 Ray Strode [halfline] 2006-01-27 14:28:57 EST
This has been fixed upstream. We will get the fix in the next evolution update.

Closing ->UPSTREAM

Note You need to log in before you can comment on or make changes to this bug.