Bug 177490 - x86_64 boot stops at "io scheduler cfq registered" with ati chipset
x86_64 boot stops at "io scheduler cfq registered" with ati chipset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-11 02:18 EST by Jens Petersen
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-13 00:00:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2006-01-11 02:18:46 EST
Description of problem:
I can get recent rawhide (fc devel) x86_64 kernels to boot on my AMD64 box.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1826.2.9_FC5.x86_64
kernel-2.6.15-1.1826.2.5_FC5.x86_64
kernel-2.6.15-1.1826.2.4_FC5.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. Try to boot boot.iso
2. Or install above kernels in say rawhide-20060103 and reboot
  
Actual results:
Boot stops at "io scheduler cfq registered" message and nothing happens.
Need to powercycle to reboot.

Expected results:
Boot normally.

Additional info:
Kernels up to at least 2.6.14-1.1808_FC5 are ok (I don't have any builds
after rawhide-20060103 and before rawhide-20060107 to test) so this started
happening recently, ie this year.
Comment 1 Jens Petersen 2006-01-11 02:21:05 EST
Fwiw NumLock is still one when it hangs just as a point of reference.
Comment 2 Sammy 2006-01-11 10:08:19 EST
Can't reproduce this on my x86_64 system. Do you have ACPI on? The new
kernels need acpi to be on. The next line after the cfq line is ACPI: PCI ...
so if you have noacpi on your kernel line, remove and try again.
Comment 3 Dave Jones 2006-01-11 23:30:14 EST
if you boot with initcall_debug whats the last thing it says ?
Does this have an ATI chipset by any chance ? (If so 2.6.15-1826.2.10 should fix it)
Comment 4 Jens Petersen 2006-01-11 23:40:18 EST
Yes it does: ATI Radeon Xpress 200.

Comment 5 Dave Jones 2006-01-11 23:42:12 EST
ok. magic 8-ball says... "Fixed for tomorrows build".
Comment 6 Jens Petersen 2006-01-13 00:00:40 EST
Confirmed fixed.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.