Bug 1774912 - console will get error when sorting by 'Availability' on the catalogsource page
Summary: console will get error when sorting by 'Availability' on the catalogsource page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-21 09:43 UTC by shahan
Modified: 2020-01-23 11:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:13:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3519 0 'None' 'open' 'Bug 1774912: Fix sorting catalog source availability' 2019-11-21 13:45:35 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:13:54 UTC

Description shahan 2019-11-21 09:43:45 UTC
Description of problem:
 console will get error when sorting by 'Availability'  on the catalogsource page

Version-Release number of selected component (if applicable):
 4.3.0-0.nightly-2019-11-19-122017

How reproducible:
ALways

Steps to Reproduce:
1. goto k8s/cluster/config.openshift.io~v1~OperatorHub/cluster/sources and disable a catalogsource by kebab button
2. Try sort items by Availability
3.

Actual results:
console get page shows: Oh no! Something went wrong.

TypeError: Converting circular structure to JSON
    --> starting at object with constructor 'Xu'
    |     property 'stateNode' -> object with constructor 't'
    --- property '_reactInternalFiber' closes the circle
    at JSON.stringify (<anonymous>)
    at Object.string (https://console-openshift-console.apps.qe-qitang.qe.devcluster.openshift.com/static/main-chunk-edf64d08212db2a6e549.min.js:1:267561)
    at L (https://console-openshift-console.apps.qe-qitang.qe.devcluster.openshift.com/static/main-chunk-edf64d08212db2a6e549.min.js:1:270224)
    at https://console-openshift-console.apps.qe-qitang.qe.devcluster.openshift.com/static/vendors~main-chunk-0d196613a62cc1eb5899.min.js:30:134240
    at t.a (https://console-openshift-console.apps.qe-qitang.qe.devcluster.openshift.com/static/vendors~main-chunk-0d196613a62cc1eb5899.min.js:12:107778)
    at https://console-openshift-console.apps.qe-qitang.qe.devcluster.openshift.com/static/vendors~main-chunk-0d196613a62cc1eb5899.min.js:30:134218

Expected results:
should work well.

Additional info:

Comment 1 Samuel Padgett 2019-11-21 13:27:13 UTC
cyclic object value

in ConnectFunction (created by CatalogSourceList)
    in CatalogSourceList (created by ListPageWrapper_)
    in div (created by ListPageWrapper_)
    in div (created by ListPageWrapper_)
    in div (created by ListPageWrapper_)
    in ListPageWrapper_ (created by MultiListPage)
    in Unknown
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by Firehose)
    in Firehose (created by ConnectFunction)
    in ConnectFunction (created by MultiListPage)
    in div (created by ConnectedFireMan)
    in ConnectedFireMan (created by ConnectFunction)
    in ConnectFunction
    in ConnectFunction (created by MultiListPage)
    in MultiListPage (created by CatalogSourceListPage)
    in CatalogSourceListPage (created by Sources)
    in Sources (created by Context.Consumer)
    in Route
    in Switch
    in div (created by Data)
    in Data (created by StatusBox)
    in StatusBox
    in div
    in div
    in Unknown
    in Unknown
    in Unknown
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by Firehose)
    in Firehose (created by ConnectFunction)
    in ConnectFunction
    in Unknown (created by DetailsPage)
    in ErrorBoundary (created by DetailsPage)
    in DetailsPage (created by OperatorHubDetailsPage)
    in OperatorHubDetailsPage (created by AsyncComponent)
    in AsyncComponent
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by Context.Consumer)
    in Route (created by AppContents_)
    in Switch (created by AppContents_)
    in div (created by AppContents_)
    in div (created by AppContents_)
    in section (created by PageSection)
    in PageSection (created by AppContents_)
    in AppContents_ (created by ConnectFunction)
    in ConnectFunction (created by ConnectFunction)
    in ConnectFunction (created by App)
    in main (created by Page)
    in div (created by Page)
    in Page (created by App)
    in App (created by Context.Consumer)
    in Route
    in Router
    in Provider

Comment 2 Samuel Padgett 2019-11-21 13:43:54 UTC
We're trying to sort the column values, but the disabled link is a React element that can't be sorted.

Comment 4 shahan 2019-11-25 02:38:05 UTC
The sort functionality of Availability works well when it has a disable link.
Verified this bug.
4.3.0-0.nightly-2019-11-24-183610

Comment 6 errata-xmlrpc 2020-01-23 11:13:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.