Bug 177525 - /etc/mtab and /proc/mounts displays rw even when mounted as ro
/etc/mtab and /proc/mounts displays rw even when mounted as ro
Status: CLOSED DUPLICATE of bug 163532
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Karel Zak
Brian Brock
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-01-11 10:12 EST by Mark Gray
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-21 06:01:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Gray 2006-01-11 10:12:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
When mounting an NFS ro export and specifying the mount type as rw from the client. The mount appears to be correctly mounted as read-only. However in the /etc/mtab and /proc/mounts files, the mount is seen to be rw. Is this a feature or a bug?

Version-Release number of selected component (if applicable):
util-linux-2.12a

How reproducible:
Always

Steps to Reproduce:
1. Export folder as read-only on NFS server.
2. Attempt to mount from cNFS client as read/write
3. Attempt to "touch" a file from the NFS client, confirming a read-only mount.
4. View the /etc/mtab and /proc/mounts files.

Actual Results:  
Files indicate a read/write NFS share.

Expected Results:  
Files should indicate a read-only share.

Additional info:


Not certain if this is a feature or a bug. IMHO, it should state that the share is mounted as read-only even if the user specified read/write.
Comment 1 Karel Zak 2006-06-26 08:00:16 EDT
I think the /proc/mounts should be indicate the right state (ro). The problem
with /etc/mtab is known problem and it's limitation of implementation (which is
described it in the latest version of mount man page).

We should update RHEL4 mount(8) man page and sync it with RHEL3 and FC5|6.
Comment 2 RHEL Product and Program Management 2006-08-18 12:48:34 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Karel Zak 2006-08-21 06:01:07 EDT

*** This bug has been marked as a duplicate of 163532 ***

Note You need to log in before you can comment on or make changes to this bug.