Bug 177526 - cdrecord writes CDs that fail mediacheck without dma=off
cdrecord writes CDs that fail mediacheck without dma=off
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-11 10:20 EST by Scott D. Anderson
Modified: 2008-05-06 11:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:33:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott D. Anderson 2006-01-11 10:20:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.7.12-1.1.3.2

Description of problem:
I burned several FC4 ISOs (for installing on another machine) using cdrecord.  The burning exhibited no errors, but the installation failed.  I checked the disks using "mediacheck," and they failed.  I asked on LinuxQuestions, and was told to use "dma=off" in the mediacheck, and that succeeded.  I'm told that the installation will succeed the same way, though I haven't tried that yet.  

The exact command I used was: 

cdrecord -v -dev=ATA:1,0,0 -eject -data FC4-i386-disc3.iso

I checked the sha1sums for the ISOs I burned and they were fine.  Burning those same ISOs using a Mac OSX produced CDs that installed just fine.  So it really seems to be a bug with CD record.

You might argue that it's not a bug, since there is a workaround, but I've been using Redhat and Fedora for years without hearing about dma=off or understanding what it means, so it seems to me that the workaround is obscure enough that this counts as a bug.  There is an "easy" workaround, so perhaps I've miscategorized the severity, but because the workaround is somewhat obscure, I've classed it as a bug.




Version-Release number of selected component (if applicable):
cdrecord-2.01.1-9.0.FC4.1

How reproducible:
Always

Steps to Reproduce:
1. Burn ISO using cdrecord -v -dev=ATA:1,0,0 -eject -data FC4-i386-disc3.iso
2. Boot from a working FC4, disk 1
3. type "linux mediacheck" at the prompt
4. test the burned CD.  this will fail.  
5. reboot from the same working FC4, disk 1
6. type "linux mediacheck dma=off" at the prompt
7. test the burned CD.  this will succeed.



Actual Results:  disk failed the medicheck


Expected Results:  disk should pass the mediacheck


Additional info:
Comment 1 Harald Hoyer 2006-01-11 10:54:57 EST
please use "-dao" for burning
Comment 2 Harald Hoyer 2006-01-11 11:01:03 EST
Also, because I think this is more an anaconda/mediacheck issue, which should
use the isosize and not the number of bytes read from the device, I am
reassigning this to component anaconda.
Comment 3 Horst H. von Brand 2006-03-22 11:52:43 EST
Again, with Fedora Core 5 media won't pass the mediacheck test here unless I
give "ide=nodma". Tossed a few (presumably good...) CDs away... CDs were burned
on a DVD writer under Fedora rawhide (almost Fedora 5).
Comment 4 Christian Iseli 2007-01-19 19:37:57 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 5 Ruth Aydt 2007-03-28 13:15:47 EDT
With RHEL V5 x86-64 on an AMD based system I get mediacheck errors on discs 1 
and 4 of the release.  I confirmed the md5sums were correct on the iso file 
images and reburned disc 1 - still get errors reported.   Tried mediacheck 
with  dma=off; still get errors reported.   tried mediacheck with ide=nodma 
and after initial progress get "Kernel alive" and "kernel direct mapping 
tables up to 260000000 @ 8000-13000" then system hangs.    Will go ahead and 
try install with these discs as not sure what else to do.  Think there is 
still an issue w/ mediacheck in V5.
Comment 6 petrosyan 2008-03-09 22:56:00 EDT
Fedora Core 5 is no longer maintained. Can you reproduce this bug in Fedora 8?
Comment 7 Bug Zapper 2008-04-03 22:06:24 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 8 Bug Zapper 2008-05-06 11:32:58 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.