Bug 1775333 - make sure x86_64 samples are not installed on s390x clusters (initial 4.2.x targeted GA)
Summary: make sure x86_64 samples are not installed on s390x clusters (initial 4.2.x t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On: 1776043
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-21 18:39 UTC by Gabe Montero
Modified: 2019-12-11 22:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1776043 (view as bug list)
Environment:
Last Closed: 2019-12-11 22:36:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 200 'None' closed [release-4.2] Bug 1775333: fetch arch from GOARCH, allow for z/ppc 2020-05-22 19:38:28 UTC
Red Hat Product Errata RHBA-2019:4093 None None None 2019-12-11 22:36:16 UTC

Description Gabe Montero 2019-11-21 18:39:42 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Gabe Montero 2019-11-21 18:53:36 UTC
This change was verified in 4.3 via the QE testing for https://jira.coreos.com/browse/DEVEXP-418

Comment 4 XiuJuan Wang 2019-11-29 08:46:22 UTC
Install a 4.2.0-0.nightly-2019-11-28-230858 cluster with x86_84 arch payload.
Steps:
1.
Set samples operator to Removed , then configure architectures to s390x and managementState to Managed
oc patch config.samples/cluster -p '{"spec":{"managementState":"Removed"}}' --type=merge
oc patch config.samples/cluster -p '{"spec":{"architectures":["s390x"],"managementState":"Managed"}}' --type=merge
2.
Check co openshift-samples. Should prompt "NonX86Platform" message.

$ oc  describe co  openshift-samples 
Name:         openshift-samples
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-11-29T08:08:57Z
  Generation:          1
  Resource Version:    20248
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/openshift-samples
  UID:                 7e2d51bf-127f-11ea-a664-02d5cfbb615e
Spec:
Status:
  Conditions:
    Last Transition Time:  2019-11-29T08:33:48Z
    Reason:                NonX86Platform
    Status:                True
    Type:                  Available
    Last Transition Time:  2019-11-29T08:33:48Z
    Reason:                NonX86Platform
    Status:                False
    Type:                  Progressing
    Last Transition Time:  2019-11-29T08:33:48Z
    Reason:                NonX86Platform
    Status:                False
    Type:                  Degraded
  Extension:               <nil>
  Related Objects:
    Group:     samples.operator.openshift.io
    Name:      cluster
    Resource:  configs
    Group:     
    Name:      openshift-cluster-samples-operator
    Resource:  namespaces
    Group:     
    Name:      openshift
    Resource:  namespaces
  Versions:
    Name:     operator
    Version:  4.2.0-0.nightly-2019-11-28-230858

3. Check imagestreams under openshift project. No x86_64 images import.
oc get is  -n openshift 
NAME                  IMAGE REPOSITORY                                                                 TAGS     UPDATED
cli                   image-registry.openshift-image-registry.svc:5000/openshift/cli                   latest   
cli-artifacts         image-registry.openshift-image-registry.svc:5000/openshift/cli-artifacts         latest   
installer             image-registry.openshift-image-registry.svc:5000/openshift/installer             latest   
installer-artifacts   image-registry.openshift-image-registry.svc:5000/openshift/installer-artifacts   latest   
must-gather           image-registry.openshift-image-registry.svc:5000/openshift/must-gather           latest   
tests                 image-registry.openshift-image-registry.svc:5000/openshift/tests                 latest

Comment 6 errata-xmlrpc 2019-12-11 22:36:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4093


Note You need to log in before you can comment on or make changes to this bug.