Bug 1775339 - Rebase flatpak to 1.6
Summary: Rebase flatpak to 1.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: flatpak
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.2
Assignee: David King
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1775345 1788067
Blocks: 1745633
TreeView+ depends on / blocked
 
Reported: 2019-11-21 18:55 UTC by Matthias Clasen
Modified: 2020-04-28 16:11 UTC (History)
5 users (show)

Fixed In Version: flatpak-1.6.1-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:10:29 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Fedora Pagure fedora-infrastructure issue 8464 0 None None None 2020-01-20 13:29:11 UTC
Github flatpak flatpak issues 3368 0 None closed Broken OCI 2020-03-17 14:20:14 UTC
Red Hat Product Errata RHEA-2020:1767 0 None None None 2020-04-28 16:11:10 UTC

Description Matthias Clasen 2019-11-21 18:55:54 UTC
The 1.6 release will include the necessary infrastructure for authenticating against repositories and registries that we want to use to install flatpak content from the Red Hat container catalog.

1.6 is scheduled to be released in December 2019.

Comment 1 David King 2019-12-02 14:47:07 UTC
Not released yet.

Comment 2 Matthias Clasen 2019-12-02 17:50:38 UTC
The release is on track to be available before Xmas. The reason we scheduled it to be released before the end of the 8.2 devel phase is that we want to use the authentication functionality in flatpak 1.6 to enable access to the rhel container catalog for the rhel runtime.

Comment 3 Matthias Clasen 2019-12-02 17:51:42 UTC
So, please consider granting an exception for this.

Comment 6 Matthias Clasen 2019-12-13 16:31:28 UTC
We've released 1.5.2 today, which is a feature-complete beta for 1.6.
1.6 will be out next week.

Comment 10 Tomas Pelka 2020-01-20 09:37:32 UTC
Unfortunately getting 404 for apps from OCI.

$ flatpak remote-add --user OCI oci+https://registry.fedoraproject.org

$ flatpak install evince                                              
Looking for matches…
F: An error was encountered searching remote ‘OCI’ for ‘evince’: Unable to load summary from remote OCI: Server returned status 404: Not Found
Found similar ref(s) for ‘evince’ in remote ‘flathub’ (system).
Use this remote? [Y/n]: n


jkoten confirmed works fine 1.4

Comment 11 Martin Krajnak 2020-01-20 12:09:20 UTC
We can reproduce the issue with upstream flatpak on Fedora Rawhide as well.

Comment 12 Jiri Koten 2020-01-20 13:29:11 UTC
This is actually an issue with Fedora OCI infra, see: https://github.com/flatpak/flatpak/pull/3294#issuecomment-565458155

Comment 14 Martin Krajnak 2020-01-29 11:56:45 UTC
Moving this to verified, as the OCI was described as the issue on the service side, not flatpak itself.

flatpak-1.6.1-1.el8

Comment 16 errata-xmlrpc 2020-04-28 16:10:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1767


Note You need to log in before you can comment on or make changes to this bug.